Midi keys are keep being played after finger was lifted

Hi I have a bizarre problem with my Roland keyboard and cubase.
When I play a key cubase record this key as still being pressed after I lifted my finger from the keyboard.
It happen when I press the keyboard instantly.
If I make a long press and then lift my finger off the keyboard, Cubase then record this and stops the key.
I browsed for midi issues on the net and all I see is latency issues and the like. But I couldn’t find similar problem like this.
Also i installed 3 other software to test this and they works just fine including FL studio (demo).
Can anyone help me with this.
I’m new to Cubase so maybe its a very simple mistake on my end.

I have win7 32bit HP laptop with Core I5. using on-board sound card.
Using simple USB midi interface to plug my Roland E-66 keyboard.

Hope someone can help,
Thanks

Weird, never heard of this. You’re not pressing the sustain pedal no? :wink:

Thanks for trying strophoid
I connected and disconnected the sustain pedal.
Same result.
First key I press works fine. The second one gets stuck as if I keep pressing it although I released it. (only when key is pressed for a short time.)
Pressing any other key for more than a second and releasing it works fine.
but the one I pressed instantly is keep showing as pressed.

Try changing the inputs of your midi track from ‘all midi inputs’ to specifically the Roland midi output.

I tried changing all input to the specific midi input.
Also tried ticking and unticking the “use system timestamp” option in “midi port setup”.
No success.
Whats making it even more bizarre is that when I go to key editor to edit the midi and change from “midi input” to “step input” and then I press record then it does work and the software is able to recognize the time when I release my finger from the key. The problem with the step method is that it records the key presses twice simoultaniously. once in the beginning of the composition and the second time at the recording time location. Its not a good option to use “Step input” to record midi keyboard I suppose.

I never use step input so I’m not really sure how that’s supposed to behave anyway :wink:
Currently out of ideas on this one, I’ll let you know when I think of something… :confused:

Does you problem only occur while playing “live” or do you get stuck notes also while playing MIDI/Instrument tracks you have recorded with your keyboard?

Jarno - This problem occur when I record Live.
The notes are heard correctly while I record but being recorded on cubase as continuously pressed.
It do not get stuck notes when I play back midi tracks which were created correctly (as in not by me).

Strophoid - Thanks for thinking of this.

OK. Could you please record the simplest possible track (one note?) which has this phenomenon and then post screenshots of

  1. Key editor
  2. List editor
    of this track.

Sure - Here are the screenshots of key and list editors. I added some text to the key editor as explanations:
http://www.sweet-art.co.il/temp/key-editor-+-text.png
http://www.sweet-art.co.il/temp/list-editor-sm.png
Thanks.

Thanks. Your second screenshot is from Project Window, not List Editor, though. But I can see why: there’s not List Editor in Cubase Elements, only Artist and Full versions :confused:

But anyway. From the screenshot I can find few possible reasons for the problem:

  1. Your keyboard fails to send NOTE OFF event (very unlikely)
  2. Your MIDI interface/driver looses the NOTE OFF event (unlikely)
  3. Cubase fails to recognise NOTE OFF (never heard it has done so)
    #1 to #3 are definitely not the case, if you don’t get stuck notes from VST synths while recording. In that case only one reason remains:
  4. Event timestamps get mangled somehow (by your MIDI interface driver) and NOTE OFF is recorded on the track earlier than corresponding NOTE ON

In the case #4 this old article is a good point on how to start debugging your problem:
http://www.soundonsound.com/sos/dec07/articles/cubasetech_1207.htm
While article only talks about timing problems, it may apply to you, because your problem may be a timing problem of the NOTE OFF event.

Hi Jarno,

Thanks for looking into this!
Few days ago I stumbled upon the article you attached.
From what I gathered the only thing I could do is tick or untick the timestamp options. all other things mentioned there are for testing but not for fixing. Anyway ticking and unticking did not solve my problem.

I guess I should be happy this happen to me with the trial version because I was just about to buy this. but I really feel bad that this bug happen to me. and as far as I can see - only to me.
:cry:

Wanted to post an update to anyone else who might encounter the same issue.

The problem is with my Roland E-66 keyboard. I tested the same configuration on another keyboard and it works fine.
I need to buy a new keyboard…

Have the same problem with my Roland G800. What to do now? Is this problem remains on every software that you’ve tried or only on Cubase? How about Pro Tools ? :question:

Hey guys. I finally found someone with same problem. Same roland G800 problem. I first tought its cubase problem but then i pluged in friends korg tr and it records perfectly. But when i plug in my roland on same drivers and everything this problem happens. I dont know what to do :frowning:

I also have this problem on my Roland RD700NX seems to effect E2 here.

Z

So lets make a conclusion. All Rolands are making problems, right? Let’s get a message to Roland, to see what will be their answer. I’ll do that for all of us and will keep you in touch.

I’m using Casio AP-25 which is very old model but it supports MIDI.
But when I tried to connect to my pc and run some vst. I had a same issue.
You can refer the youtube video that I reproduces this problem.
This happens not only in cubase but also in other applicaton such as musescore.

https://www.youtube.com/watch?v=BDlKwBNtUnA


I think I need to make final conculsion that this is problem from my digital piano.

If anyone has better idea for this issue, please reply to my post.
Thanks

Because it doesn’t happen to every key it looks like the sensors in your keyboard are simply dead.

Hi Jarno, I have the same problem but instead playing live I have a problem with tracks I recorded with my keyboard. I imported a MIDI in Cubase that I have recorded in my keyboard and when I press STOP inside my Cubase 9.5 (Full version) instead of stoping pad continues to play, actually it get sucked. Please, if you could be helpful and send some idea how to resolve this issue. Thanks