MIDI Latency / Delay

Hello… this is my first post, as I usually find the answers I need, but after a while looking into this I’m still struggling.

In a nutshell, what is happening is that when I hit a key on my midi keyboard, it’s got a delay before the VST plays the note. I have tried all the different VST’s I have and it’s the same on them all.

I have tried to make adjustments in Cubase and on my sound card and it’s not making a blind bit of difference.

Here’s what I’m running…

Cubase 8

4gb 8 core AMD 8350 FX

32gb RAM

AMD Radeon Graphics Card

MOTU 2408 mk3 sound card, with PCI / Firewire (Sample rate - 44100 / Buffer size - 128 / set to internal clock source)

M-Audio keystation 49e USB (old but still works ok)

Everything else is all on board (VST’s, synths and such) no out board or conventional midi operated equipment.

I’m using the MOTU driver for my sound card, mulit processing is checked and ASIO guard is activated and set to normal.

(Release driver when in background is unchecked)

Input latency - 3.401 ms
Output latency - 3.424 ms
ASIO Guard latency - 23.220

I’m probably being stupid here, but I never had these problems before when I was running Cubase 5, I just upgraded to Cubase 8 and everything about it is awesome… apart from this!!!

thanks in advance for any help you can offer! :slight_smile:

I sometimes have this problem with Cubase 6 Artist, not seen it on my C8 trial yet and am keeping my fingers crossed. I can only clear it by turning everything off and starting again.

Is the delay in getting into Cubase or coming out?
When I have the problem I see the MIDI signal is reaching Cubase immediately (from the input monitor on the transport bar) but there is then a delay before the sounds (internal or external are played). This may or not be pertinent in your case…

Thanks for your reply!

You know, I’ve not properly checked that.

I’m pretty sure it’s the signal coming in, and whether I turn off and on again, it doesn’t make a difference!

The delay is there from the moment I turn Cubase on, and it stays there no matter what I do!

I experienced the same exact problem last week and the cause was one of the effects plugins that I had on the master bus (multiband compression). I’m not sure exactly why this one is a problem, but it could be due to something like look-ahead functionality which I believe incurs a (potentially large) latency.

Anyway, try the following: 1) open a new project (with no plugins whatsoever); 2) insert just one low-latency instrument VST (e.g., HALion Sonic SE); 3) load a patch with a fast attack (e.g., a piano); and 4) hit a key on your MIDI keyboard. If this solves the problem, start loading in the plugins you usually use (one at a time) and repeat the test until you find the one that’s causing the delay. Cheers…

I’ll have a look at that when I have a go next, I use the multiband compressor on the main out bus, so maybe this is causing the problem!!!???

Thanks for the replies chaps!!!

Turning off the Multiband Compressor on the Stereo out worked!!!

Thank you!!!

My pleasure…

I’m getting something very similar, although I’ve been able to eliminate the chance of the problem being caused by high-demand plug-ins…

For the first couple of weeks of the Cubase 7 Elements trial everything was fine, until randomly one day, halfway through recording some midi information, I started getting about a half-second delay between hitting a note and an sound.

It happens if I use a MIDI keyboard via an M-Audio Midisport 2x2, and using an SPD-SX via USB. The MIDI I/O indicator registers the midi information in and out at the same time, but with the delay, but if I’m recording a MIDI part, the note is in the right place. The delay occurs whether I’m using a MIDI controller to record another MIDI instrument or a VST instrument.

When I fire up Cubase and start work, I can play MIDI in with no delay for sometimes up to a minute, sometimes as little as 20 seconds, before the delay starts happening, and it only does it when Cubase is in record or playback mode - if it’s just sitting there doing nothing then it passes MIDI thru with no delay.

Things I’ve tried:

Working in a blank project with no other tracks, no audio processors open, no plug-ins running, no nothing else, besides a single MIDI track playing single notes with no aftertouch or any other controllers.

Reset MIDI devices.

Use system timestamp (checked and unchecked)

Constrain Delay Compensation (on, and off).

Using different ASIO drivers.

Externally clocked (checked and unchecked)

I’m kind of running low on ideas, and running out of days left in my trial - I don’t want to have to end up buying a piece of software that isn’t going to work properly, just so that I don’t lose the work I’ve alread done since I started using it if I’m going to end up using a different DAW in the long run.

I had the same using MB Compressor on an audio channel being monitored and driven from a MIDI track. The MIDI was playing a HW bass synth.

When I added the MB Compressor the timing between the bass and drums went to rats. Switching the compressor to ‘live’ solved the problem.

I found this thread after discovering the latency problem in Cubase 8.5. I tried disabling all the effects and even tried soloing the VST track that was experiencing the latency. Nothing was helping.

I finally discovered the problem was that the VST track’s output was set to a group channel. I normally use group channels to save resources on effects, but in this case, it was causing latency. As soon as I switched the output of the VST back to Stereo Out, the latency disappeared. After I finish recording the MIDI parts that I need to record, I can switch the output back to the group channel.

My setup:

Windows 10 64-bit
Intel Core i7 4790k
32GB RAM
Cubase Pro 8.5.15
Steinberg UR22mkII USB audio interface with v1.9.8 drivers

I hope this helps someone else!

Steinberg’s support wrote me back about this issue and suggested toggling the “Constrain Delay Compensation” button in the main toolbar (looks like a little clock) while recording new parts. I guess this turns off the high latency plugins during playback. It works very well.

Thank you so much for posting this… I forgot playback timing is dependent on the master bus…

Your wrote:

I experienced the same exact problem last week and the cause was one of the effects plugins that I had on the master bus (multiband compression).


Your post solved a demon that I had for about a year. It happend when I went to final a song, added mastering plugs and
then had to go back to fix a track with the fishman triple play… I am betting a ton of users are brain-farting like I did.

Hey all,
I would like to revisit this post rather than start a new one because I have tried all the options here and none seem to be making a difference for me. Just wondering if anybody has had the same issue and found a different resolution.

I’ll restate the problem to specifically address what I am experiencing.

I have created 5 external instrument midi devices each connecting a separate midi port to a physical synthesizer (they are all rack mount synths without keyboards).

Hardware:
Dell PC - Intel i7-6700 3.40GHz
Memory - 64GB
Using SSD Drives
Motu 828mk3 with Focusrite OctoPre Mkii audio interface
MidiSport 8x8/s Midi interface

Software:
Windows 10
Cubase 8.04

Problem:

  1. When I first start Cubase 8 all the synths respond to my midi controller (Roland A-90) with no or so little latency that I don’t hear it.
  2. After playing on any of the instruments for a minute or so, all the synths have about a .25 second latency. If I switch over to a VST Virtual instrument there is no latency.
  3. If I quit playing for a while the latency goes away.
  4. If I start playing again the latency comes back.

It seems like a buffer problem to me and there is probably a setting somewhere that will correct the problem, but I have not been able to identify it.

Any Ideas???

Thanks

Hi
Same issues with me. I have just started playing around with Midi, and have a latency of about 1 - 2 secs or so.

Gear:
Cubase Elements 8
Windows 10 - 64
8gb Ram
1Tb Disc
M-audio Accent Piano connected via midi out to cumputer USB ( with conversion cable).
Not the most flash gear but works fine with anything I have used except MIDI :slight_smile:.

The midi element of the piano is showing up fine in both Windows and Cubase. Added Midi track using Halion Sonic SE2, tried out various instruments. Midi output shows up immediatedly in the transport bar and the monitor part of the track. I have NO effects in the signal path at all, yet this latency on producing the sound. I have recorded some sound on a track, on play back noticing the position of the track marker, the sound doesnt appear when the marker crosses the signal but about 1- 2 secs after, so I have latency on playbeck as well :frowning:, any help appriciated?

Cheers
Alan

Audio Interface?
Wahtz is the MIDI track triggering? MS Wavetable synth?

Hello Everyone,
I’m having the same issue with my Midi … Using a USB powered M-Audio Keystation 49ers … running it into Cubase and have a bad latency. Tried changing the buffer size and its the same throughout!! Never had this problem with Abelton Live. Any suggestions???

5 years latter, today I had the same problem and applied the same solution! It was the multiband compressor in my master bus. Thank you!

Yes, this resolve the problem. I had the same problem and and watched the stereo output activating and deactivating the constrain delay compensation y a saw that immediately this deactivated one Waves AT GT mastering plugin, so, I decide to quit it and al my vst come alive in time without the need to use that button. The same if did some parameters changing in that plugins and don’t want to move it, only activate this button solve the problem but deactivate the plugin which causes the latency. That’s it.

Yes, this resolve the problem. I had the same issue and I watched the stereo output, activating and deactivating the constrain delay compensation and I saw that immediately this deactivated one Waves AT GT mastering plugin, so, I decide to quit it and all my vst come alive in time without the need to use that button. The same if I have done some parameters changing in that plugins and don’t want to move it, only activate this button solve the problem but deactivate the plugin which causes the latency. That’s it.