Midi Latency Issues with Cubase 6.5

I’m having a strange problem with Cubase 6.5, 64 bit. What happens is that i start a new project, load up any drum sampler in the VST rack, and at first it plays fine, and nice and tight, then after a little while (anything from 15 minutes to a couple of hours) there is a latency lag when i try to play in any midi notes.

I have a M Audio Delta 2496 PCi soundcard, and the buffer settings are set to 256, and the latency shows up in Cubase at around 6ms. When it goes wrong, the settings still shows 6ms, but in reality it is more like 40ms, which is hard to work with for finishing off drum loops, or playing in any kind of midi notes live. I upgraded from Cubase 6 to 6.5, bought Novation Focusrite VRM and a Novation Impulse 25 keyboard around the time that it started to go wrong. I have tried different combinations of the three, sometimes uninstalling stuff and have even used my old keyboard but it did n’t make any difference.

Things i have tried include…

a System Restore in Windows
re-installing Cubase 6 without the update
re-installing Cubase 6 with the update
re-installing Cubase 6 with 5.1 update
re-installing Novation Focusrite VRM
uninstalling but not re-installing Novation Focusrite VRM
re-installing Novation Focusrite Impulse 25 Keyboard and Automap software
updating soundcard drivers to the latest drivers
updating soundcard drivers to the one before the latest drivers
updating graphic card drivers
uninstalling and re-installing graphic card drivers
using Groove Agent One drum sampler
using Geist drum sampler
using Poise drum sampler
putting the PCi soundcard in a new slot
doing a repair install of Windows 7
starting a completely new project
trying different settings with Time stamp etc…

and the same thing happens time and time again, without fail.

As you can imagine i am all out of ideas, other than doing a full re-install or buying a newer soundcard. I am prepared to do these at a push, but they have the obvious negatives of time and money respectively, and at the moment i’m not feeling that confident that any of these would work.

I was wondering if anyone has had similar problems to this after either upgrading Cubase from 6 to 6.5 or buying Novation Focusrite equipment, or if anybody has any other suggestions before i take the plunge and try the full re-install or new soundcard route.

Thanks in advance for any help or advice

I personally don’t raise alarms until I’ve done the other thing you suggested, however a new sound device would not go astray in particular one that supports the proper standards such as MMCSS/WASAPI, as this in the least will give you no-latency playback.

Try switching off “Adjust for record latency” in Device Setup (VST Audio System) to see if your delay is anything to do with plug in delay compensation, as it could be a plug in causing extra latency that your audio card driver would not show.

I don’t think you would want this parameter turned off permanently, but worth a test though.

Thanks Guys,

I will look into getting a new soundcard, but i wanted to try any suggestions that don’t cost any money first, naturally.
Keep them coming. I will try any suggestions when i get home from work later, and i’ll update this thread if i have any success.

Many Thanks

Maybe the PC and OS resources are getting overloaded by VSTs and new HW drivers. Plenty of RAM?

M-audio were never really up to the mark with established standards such as ASIO 2.2, moreover they are known for hacking together previous generation software and forcing it to work on newer systems without respecting OS standards (something Yamaha also did before Steinberg partnered with them).

@ SteadyEddie - Sorry, i forgot to post my specs.

OS - Windows 7 64 bit (Service Pack 1)
CPU - Intel Q6600 2.4 ghz Quad Core
RAM - 6 gig of DDR 2

@ artisan - Thanks for the info, I did n’t know that.

New computer wouldn’t be amiss. Keep the soundcard.
I smell the sound of cooking components.
You could also try cleaning the fans and crannies.

2211, I’m having similar issues, here’s my specs

Win7 64
AMD 1100t 6-core 3.3ghz
8gb ram

The lag happens almost every time I dissolve a midi drum loop, very frustrating, it seems Cubase related to me.

Oh I just found the answer, and it’s using the Constrain Delay Compensation button which I’ve never touched once in my 3 years of Cubase usage! The manual explains it all.

Thanks tpmears. I googled this problem and this thread came up. You saved me a lot of time.

Yeeeeez, this finally solved my latency issues! Damn, why all of the sudden does this button needs to be pushed? Never once laid my hands on it and experienced no problems in C5 or C6.5…

Does the “Constrain Delay Compensation” function really add up when the OP stated it was a time-dependent problem (not there on firing up Cubase, then develops after some time has gone by, of varying amounts)?

In other words, why would pressing CDC not be necessary for good timing right off, but then become needed later?