MIDI latency issues

Hello Cubase users, I wonder if someone can advise me.
I bought a bigger machine, mostly to help me with Dorico. It’s got an i7 processor with 32 GB RAM. So should be ok.
But when it comes to MIDI recording, I get latency of about half a second from my input keyboard, when I’m working with either ASIO4ALL or with the inbuilt “Generic Low Latency ASIO Driver”. The only way I get no latency is with my UR44.
This is a nuisance, because I don’t want to be working with the UR44 for basic stuff like this. And it’s disappointing, coz my last machine (16GB RAM) handled MIDI input with zero latency with all three drivers.
Is there something I’m missing that will optimize MIDI input? The new machine is free of bloatware.

Hi,

I expect by the “MIDI Latence” you mean latence when using Virtual Instruments, right?

One of the reason to use hi-quality Audio Device is to decrease the latency. The driver is crucial here. So I’m glad to hear UR44 has much lower latency than ASIO4ALL.

Dear Martin
Thank you for your reply. Yes, I am inputting with a keyboard using VST sounds.
I’m glad that you are pleased by the performance of the UR44.
That still doesn’t solve my issue. My last (lower spec) computer, which broke down, used my Generic ASIO Driver and ASIO4ALL without any latency. But now this higher spec computer gives latency with both. In fact, I can’t even connect up the audio inputs with the Generic ASIO. Like this…


So it seems to me that the issue is something to do with the Cubase set-up on this machine.
Have you any tips about what might be wrong, please?

Hi,

Could you try to reinstall Cubase, please? Make sure you:

  • Download the Full Installer.
  • Unpack the ZIP file and install from the unzipped folder.
  • Install from the setup.exe.
  • Install as administrator.
  • Install to the system © drive.

Then I would recommend to test your system by using LatencyMon utility.

The pc may be a better spec but the inbuilt sound chip is probably not. They are not designed for low latency you so get what you get. If you have tried asio4all and it is still high then I suspect you are stuck with it. I actually disable the onboard sound in bios as they are really not worth bothering with.

Generic asio driver is unusable always in my opinion but asio4all should work. Did you check the buffer size for asio4all in its control panel?

Yes, but ASIO4ALL has started to pump out non-stop alert messages while I work, telling me about my sample rate. They pop up continually at the bottom of the screen. Like every five seconds. Continually.

Sounds like motherboard issues to me.
What was your old motherboard ? and, what is your new motherboard /
I have had problems like this in the past. When i buy a better spec now i always use a gaming board.