MIDI latency problem

Hey everyone,

I have a strange thing that happens to me sometimes with Cubase where I’m working away and have no problems at all with MIDI input latency, but then all of a sudden I notice that when I play my midi keyboard connected into Cubase running a VST instrument, I have a very noticeable MIDI latency which makes it un-playable.

Since it doesn’t start off that way, I have thought that maybe it’s because I have too much going on in my project, but if I go and disable various things, or even remove tracks altogether, I can never get it back to having (essentially) no MIDI latency.

It only effects when I play my keyboard… the VST’s run just fine within the DAW from MIDI data in the track. If I start a new project, even without restarting Cubase, I don’t have this problem. I’ve tried restarting Cubase, my computer, my MIDI controller and nothing helps. It’s like something happened (some obscure setting?) automatically and I can’t undo it.

Any suggestions?

I’m using Cubase 7.5.20 | Roland A-800 | Windows 7 | Connected via USB


Jeff: Click “Constrain Delay Compensation” top left on your toolbar when recording.
IMO turn it off for playback :wink:

Jack :smiley: :smiley:

Thanks, Jack. I’ll give that a try tonight!

Ok, I tried the Constrain Delay Compensation and that did work… I’ve never tried that function before so thanks for brining it to my attention. I saw that it disables most of my insert plugins (but not all). Is there a rhyme or reason to which plugins it will disable?

Also the thing that I’m still confused about is what changed in my project that made it get into the state where this midi latency was introduced? Because it’s not like it gradually got worse and worse as I added things to the project. It was like flicking on a switch of midi input latency. Also, in the past I delt with this problem by rebuilding my project from scratch and in the end I was able to have no midi latency at all in the new project, but I had all the same stuff in that project as in the original one which had the latency problem.

Thanks again for your input, Jack.


Hi Jeff,

some plugins (many plugins) induce latency to your project, because they need some time to process the audio signals going through them. Cubase compensates this latency automatically, so that everything is played back in sync. You won’t hear this delay during playback, of course. However, if you want to record, you will definitely notice that the playback is delayed when comparing it to your input signal. What the “Constrain Delay Compensation” does, is disable all those plugins that induce this delay to your project, so that you can record without latency.

I hope this anwersw your questions.

Best regards

Hey Luis. Thanks for the info. So the plugins that are not disabled when I engage Constrain Delay Compensation are the ones which introduce no latency?