Midi modifier automation doesn't work properly


In order to split my midi keyboard, i use “midi modifier” to filter notes.
It works well, but when I try to automate the min/max value, the automation track has some issue.
For exemple, if I draw an automation point on that track, the value shows “C-2” wherever I drag that point.
So i’m unable to automate because the project always read that automated value as “C-2”.

Is there any way to fix this?

Hi and welcome,

This is generic Automation approach (it’s designed like this). The value in this field shows the current value, where the cursor (playback head) is. The edited node value you can see in the Info Line.

Thank you for you reply but I think I’ve been misunderstood:
WHEREVER I move the automation node, Cubase reads always “C-2”! If I try to insert the value manually in the info line, for exemple “B3”, when I press enter, the value return instantly to C-2. The track is not locked, and SOMETIMES, but only sometimes, if I restart Cubase, I’m able to modify that value.

I think this is a bug…


I see, now I got it.

Are you sure you automate the MIDI Insert > MIDI Modifier? Be aware, there is also MIDI Modifier dedicated tab. May you automate this MIDI Modifier parameter instead of MIDI Insert MIDI Modifier. Could you double-check this, please?


Yes, I have checked: the problem occurs both automating the Midi modifier parameter and automating the Insert Midi modifier.


Sorry I was thinking about something different. Are you sure you automate the MIDI Modifier, when the MIDI Modifier tab is shown or the MIDI Insert MIDI Modifier, when the MIDI Insert MIDI Modifier is shown, please?

Hi! Yes, i’m sure!


Now I can reproduce it. There is an other issue in fact. The issue is, once you set the MIDI Modifier Random or Range Target, the automation of the Random/Range Min&Max 1 & 2 disappear from the Automation Parameters. This is the source of the issue.

If you make an automation track with the Range1Min (or any other of the affected parameters) beforehand already, then the result is what you have described (the core is, because the automation track doesn’t exist for this parameter anymore).

So yes, I can confirm the bug. Already reported to Steinberg.