MIDI Modifiers -> Random (only works after rec. + playback)

The MIDI Modifier for “Random 1” and “Random 2” don’t randomize the MIDI until after it’s recorded and played back. Can we get this to work live as the MIDI comes in???.. in the same way that the MIDI Modifier “Transpose” or “Velocity” works? They modify the MIDI as it comes in… not sure why the “Random” ones don’t work live… but it would be nice if they would.


You can use the MIDI Insert MIDI Modifier and enable the Record Output to Track option.

Nope, doesn’t work at all.

Doesn’t randomize it live or played back with Record Output to Track option activated. With it de-activated, the MIDI Modifier MIDI Insert works the same way as the MIDI Modifier tab.

Found a solution!

Martin’s suggestion doesn’t work at all, but Input Transformer was able to do the job just fine.

It’s just slightly inconvenient and it makes no sense that it can’t be done in the MIDI Modifier section, but it got the job done. I’m not sure if it’s a bug or if it’s by design, but Steinberg should probably look into making all the MIDI Modifiers work live; not just some.