Midi Monitor not following input midi data

I am about 1 week into my trial version of Cubase Elements. It has been very good, but I have one issue that is a show-stopper for buying the full licence, so the clock is ticking.

I have a Roland TD30 drum kit set up for recording in Cubase. Midi thru is enabled on Cubase, local control is off in the TD30. I have one single midi track with monitor selected on the inspector. Monitoring is at the TD30. I am using ASIO4ALL, Windows 10 PC with Realtek HD audio drivers.

The issue I have is that when recording, the hi-hat in the monitor stops working – after the first press of the pedal it remains ‘locked’ down. When I play back the recording, it is perfect, so the correct midi data is being transmitted. After the playback, the open pedal is restored (until pressed again). The TD30 uses CC messages (Foot) to transmit pedal position.

I had mistakenly thought that midi thru was ‘hard wired’, but have discovered it is not (e.g. drum map is used). So there must be some other processing going on to change the midi to the monitor, but I cannot find any settings or controls relating to this. I have been over all other settings several times, but cannot find anything.

I’ve searched the forum and the web, but cannot find anything relating to this. Can you please advise if this is a bug, or what can be done to rectify it? Many thanks.

Best regards,

Don Shaw


Please ignore this technical issue, I have managed to resolve it.

I spent the morning checking settings on both sides of the midi interface, and updated the Cubase software. I also found the midi channel was incorrectly set - probably my finger trouble in chasing this issue. Now the whole setup is working fine.

Sorry if I have troubled you unnecessarily with this, the good news is that Steinberg will probably have a new Cubase customer.

Best regards,