MIDI not recording

Probably it’s an easy fix for the experts but one puzzle for me.
I normally work with audio tracks but this time I wanted to record some MIDI tracks.
All seems fine, I can hear what it’s been played through Halion Sonic, the recording is armed and all.
Now, when I hit the record button the recording seems to be in progress, the bar on the timeline indicates so but as soon as I press stop the bar disappears and the track is empty.
Any ideas why?
Tried some other MIDI instruments but they all behave the same
as in the clip:
https://www.youtube.com/watch?v=geHwWxOQ_nM
Cheers

Have you set the left (start) en right (end) locators on the region where you want to record? Make sure you don’t have ‘punch points’ active! They overrule the locators and default on 0 if you haven’t set them! I’ve had my fun with them in the beginning when they were first introduced! :slight_smile:

You can also press record during play to start recording from there regarding that the track is armed (red button) for recording and see if there might be another issue that prevents you from recording normally?

Thanks! Checked what you have suggested - the markers were wide spread at first but this time I narrowed them down just to see, punch in and out not active
Did another test with two tracks audio and midi recording simultaneously and play-record-play action but no change :confused:

I can’t exactly see on the video what goes on with the midi input/output but you seem to trigger an audio file as well that starts recording at the same same time?

Create an instrument track and select a synth. Only select this track and then try again.

yep, in the second clip the first track is an audio track and the second is an Instrument Track.
This is to show that the audio track is recording correctly whilst MIDI not
Recording MIDI track (Instrument) only here:

As I said in my first post, I can hear everything, midi in/out seem fine …

I don’t see any midi input in the screen so that may be your problem? You have to make sure that any note you play on Halion is echo’ed back to you.

Get rid of the audio track, close this project! Open an empty project and then do the same. Open an instrument track and record again.

How are you trying to record MIDI ? Do you have a physical MIDI controller for this ? Or are you clicking on the keys in the instrument window ?
You don’t say much about your setup so we can’t guess.

If the MIDI track does not receive any data during the recording, then the Part is automatically deleted when you stop. This is the issue, nothing reaches the track, and clicking the instrument keys with the mouse will not record anything, you need to use either the on-screen keyboard (Alt+K) or a hardware controller.

thanks for your input Nickeldome, much appreciated! I mean it :+1:

At this occasion I click but normally I would use some keys as triggers. I’ll do this test in a moment . Your second paragraph may hold the answer, let me double check a few things at the same time.
Thanks Louis

Off-topic posts removed. Please remember that this is a public forum, and other users may chime in at any time to try to help. Nothing wrong with that.

1 Like

Back with the results!
After I connected the keyboards (Korg X5D if it makes any difference) the recording works, I can see the played notes and the recorded segment stays in after stopping the recording.
Wasn’t aware that external instrument is must to record midi, for some reason I thought clicking would be enough. Live and learn
Thanks everyone!
Dom

Oh, and I restarted Cubase in between

1 Like

Sorry MusicTarantula, It’s not your fault in any way! I just tried to help you but the ‘regime’ had different plans.

Still hope you get your issue sorted?

1 Like

Thanks mate, sorted now.
Without stirring things up, you both guys helped!

Great, I’m glad we could sort this out.
Yes, the keyboard displayed in VST instruments windows does not output any MIDI, you just cannot record like this. It’s only for playing the sounds internally.

@Nickeldome Thanks for trying to help too :beers:

Glad to hear you got it sorted out!