Midi not stopping

After a take, some MIDI notes continue. I have to go into the key editor and remove them.

Any ideas how I can solve this issue?

I’m using an M-Audio 88 Keystation. I don’t encounter this problem with other DAWs.

Thanks

There are a few things that could be happening, such as your keyboard is not sending out the proper MIDI note off message, but there are a also a few ways to reset at the end of a segment. Please look in your operations manual for “MIDI Note Off” and also check out the information such as “The Reset Fuction” (Pg. 104 of the .pdf version of the Operations Manual). Also, in Cubase, open Preferences (MIDI page) activate the “Insert Reset Events after record” function. The list editor or key editor should provide a clue as to where things are going wrong.

I get this a lot. It happens in C5 too.

I usually end up with an extra note, that stretches from from the start of the first note i played, to the end of the MIDI event. The actual notes that I do play, are superimposed on top of the long one. It’s almost like there’s a double “note on” event recorded at the start of the first note…

Another thread about it here: http://www.steinberg.net/forum/viewtopic.php?f=19&t=6187

Thanks for the replies. I changed the “The Reset Function” as you suggested and that seems to have done the trick.

Many thanks!