MIDI Not Working AT ALL

Hey everyone,
Ok so I’ve been stuck at this for days now. My MIDI is not working at all. Cubase recognizes the MIDI keyboard I have connected, but it does not recieve any signal from the keyboard. Even the virtual on-screen keyboard (alt-k) is not working! And to top it off, I can’t even record MIDI just using my mouse to click the HALion piano on the screen. I hope this makes sense. I have updated all of my software, restarted my computer, I’ve tried it all. Please help!

Hi and welcome,

Hardware
Can you verify Cubase does/does not receive the MIDI data from your hardware controller? Can you see incoming MIDI signal on the Transport Panel? On the left side of the Audio Activity meter, there is MIDI In Activity. Can you see the signal while playing on your keyboard?

Also try to open Studio > Studio Setup. Make sure your hardware is enabled in the MIDI > MIDI Port Setup. And make sure the MIDI Port has not been used by any Generic Remote Device (Generic Remote Device, Mackie Control…), nighter Quick Controls, please.

Is Record enabled on the MIDI Track? Do you use MIDI Track or Instrument Track?

Virtual Keyboard
The signal from the Virtual Keyboard is not show on the Transports’ MIDI In Activity (as the hardware is). The Virtual MIDI Keyboard is routed to the All MIDI Inputs. So if you want to use Virtual Keyboard to any MIDI Track Input, make sure the All MIDI Inputs is set as an Input.

Is Record enabled on the MIDI Track? Do you use MIDI Track or Instrument Track?

HALion Sonic SE (and other VSTis) virtual keyboard
MIDI data from the VSTis virtual keyboard is not routed back to the MIDI Track. The MIDI data is routed to the instrument itself only. So you can’t record MIDI data from the VSTi virtual keyboard to the MIDI/Instrument Track.

Thank you for your reply! So i downloaded the new update for cubase, and now i can see a signal in the MIDI In Activity, which was not there before. Everything else that you mentioned is already all set. My keyboard has two sections, one with pads and one with piano keys. The piano keys are not recording but the pads are, which is strange. Also, in the past i have used my mouse to click on the EZDrummer drumset to record (hope that makes sense). I can’t even do that now. So I am recieving signal, but can’t record.

UPDATE:
I just unplugged and replugged my midi controller, and now Cubase is recieving no signal again…

Hi,

So it doesn’t work again…

Could you double-chceck the Remote Devices settings, please?

Does the keyboard send the MIDI data over other MIDI Port then the pads?

I would be really wondering, if this would work. The virtual instrument would to need create a virtual MIDI Port.

Everything seems to check out. Its weird, sometimes when I open Cubase, the pads work, and other times they dont. And I do not believe that the keyboard sends the midi data over other midi ports than the pads.

So I’m having the same problem with Midi data not being received or showing up. In Studio Setup under MIDI Port Setup it isn’t noticing any ports even though I have connected a keyboard. yesterday I installed the Free Komplete Start to cubase, and then used symbolic link to transfer files onto my hardrive. Initially Cubase said many of the Halion plugins were missing when I tried to boot up, so I went to Library < Application support < Steinberg and found that it was missing some files that were originally there; It only contained Components and under that two Komplete bundles. My guess is that when I installed the new Komplete Control software it souldn’t find the file because my hardrive wasn’t plugged in so the symlink wouldn’t have worked, so it simply made a new file containing only the Komplete Start bundles. So to fix this I transferred these new plugins to the original file in my hardrive, created a new symlink in the ‘Steinberg’ folder and everything then booted up fine. BUT now Cubase isn’t receiving midi on any of the Kontact instruments or Halion (or any other virtual instrument). I am VERY confused… Any Ideas?

Hi Hydrargyrum and welcome :slight_smile:

I had something similar a while back.Here’s what I did ;

Unplugged my USB cable. Downloaded the latest midi drivers for my keyboard. Found another USB port,and plugged the cable back into the PC.
then these following steps :

  1. Under the Studio tab at the top, click to “Studio Setup” at the bottom of the drop down menu and hit Reset ,this will reset all the midi ports.

2)) Found the “Mid Monitor” in the Midi inset section on the left hand side ,Inspector tab,that was very useful.As I played my keyboard I could see what midi data was being sent from my keyboard to Cubase
( How to use,set up an instance of instrument track, say Kontakt then locate Midi inserts and find Midi Monitor)

Also be good to check the global setting of your keyboard,on the keyboard itself just in case of anything there
No expert here,but hope you find this useful,

If you find that you can’t see any midi input in Cubase again, use Step 1 above :slight_smile:

Wondering if you figured this out. Just crossgraded from Cubase (which worked fine) to Nuendo and now I have exactly the same issue. Got to be something simple but I can’t find it for love nor money…

https://www.steinberg.net/forums/viewforum.php?f=290
But even there, some useful info might be necessary.

Perfect. Thanks! Got it working again.

How did you resolve your issue? I just cross-graded, MIDI works in other software but in Nuendo I see the MIDI monitor moving when I play motes but no instrument will play (they are set to All MIDI inputs).

Hi and welcome,

If you can see any MIDI activity in the MIDI Monitor, the MIDI data pass thru the track. So the issue is most probably in the instrument. What instrument do you use? Is any sound/preset selected/loaded? Maybe a screenshot would help here.

I found the issue, which was just user error. I was using the default preference settings, which does not arm the instrument track on selection. Do you know if I can use my Cubase preference settings with Nuendo?

Hi,

By default, all track types enable the Record when you select it in Cubase. In Nuendo, the Record is not enabled by default, once you select the track.

Yes, you can use your Cubase preferences in Nuendo.

1 Like