Midi note data is doubling

Great ! I thought about local settings but I didn’t think this could be the cause actually :sweat_smile:
Was that the Local switch or another setting ? It’s weird that the local control would feedback its incoming notes to the MIDI Out alongside the “input” MIDI.

well here’s the thing…it “feeds back” because I need to have my MIDI Thru enabled because I’m playing a lot of external midi modules and without the Midi Thru being enabled I couldn’t play the module in real time…only on play back so I had to enable it…but I forgot to disable the local midi feature on the boards. I’ve been away from this for quite a few years and forgot about the midi local.

So now with the local off I would play the keyboard and if I wanted to play a sound patch within the board I was playing local should be off and let Cubase send the midi signal back out to the board. So I;m playing/hearing it indirectly. The latency is very small so it’s almost not noticeable actually it’s not noticeable at all because I’m monitoring with my Behringer XR18 digital mixer…not through Cubase.
I think my set up is a bit uncommon I guess. This is why my learning curve is so steep.
Thanks again for your help. It made all the difference!

1 Like

Yes I understand the setup, it’s actually how it has to be done to work with modules, you need the MIDI Thru enabled in Cubase. It’s not uncommon :wink:

What I was saying is that the Local Switch on hardware instruments generally don’t send MIDI data an additional time, this is only for triggering or not the integrated sounds when you hit the keyboard’s own keys.

The flanging effect is only a consequence of the hardware instrument receiving the MIDI data two times consecutively, one time from pressing its own keys, and one time from Cubase MIDI Thru when the MIDI Track is monitored.

For example, if I want to monitor my keyboard directly through the hardware mixer, I turn off MIDI Thru in Cubase so that the sound doesn’t trigger two times when pressing keys while recording on the MIDI Track. If I instead want to monitor the keyboard via Cubase, it’s the keyboard’s Local Switch that needs to be disabled. But in neither case the MIDI data is received and recorded two times by Cubase, even when both options are active at the same time. At least this is how it works with my Juno Gi.

That’s why I said it is weird. While this is a real thing with hardware instruments, this basically cannot happen with VST instruments, unless the MIDI data is sent two times by the keyboard, which is quite uncommon. Maybe it works a bit different with yours, it seems that the Local Switch also have its own MIDI Thru, so when you hit a key, the same data goes out two times at a slightly different timing.

Hmmm good point. I have to really thinking about the signal flow.
Yeah local control is to shut off the (or on) the onboard midi when playing local sounds so it doesn’t echo back from the DAW.

It has to be a setting in Cubase I’m missing…no?
I’m having another issue that I just posted with midi device not being recognized by Cubase at all. It’s a 3 fader midi controller for various CC controls…it doesn’t work and I suspect this may be related to the doubling issue I had.

I feel very uneasy when stuff like this happens. It means something isn’t set up right.

I don’t think there are settings other than MIDI Thru and monitoring modes that can be tweaked in Cubase, regarding the doubling notes issue you experienced.

I think your keyboard does the following :

Standard “controller” mode :

  • Key press → MIDI Out (the generated MIDI goes directly though the Output)

And with Local Control enabled :

  • Key press → Sound module → MIDI Out (the generated MIDI triggers the keyboard’s sound and still proceeds through the Output)

So the generated MIDI data is duplicated and takes these two routes at the same time, hence the double recorded notes. And since the sound module may take a brief moment to process, the two MIDI notes are slightly offset, which explains the flanging/chorus effect when playing your VST instrument.

If you want to use Local Control without this happening, you should investigate for other MIDI related settings on your keyboard. I’m quite sure there’s a setting for it. If there isn’t, well you’ll probably have to live with it :slightly_frowning_face:

This issue you had with the keyboard should not affect other controllers, since you managed to fix it by toggling a single setting. That was just related to the keyboard.

Ahh ok thanks Louis. It’s a General Music S2 Turbo model. Long retired and the company is out of business. This board is a workstation. I got it long before I was using a DAW because it had a great sequencer and it has a lot of features that made non DAW work easier. I’ll pull up the manual
I’m looking at the screen on it now. It’s a graphical flow chart…it shows Local to track…Generation to track (I think this one might be the one to mess with) then Midi input port and Midi input channel. Then Midi output port and midi output channel. It’s a two port 32 channel board. I’m sure you’re right about the configure on the board. I’ll see if Generation will do it if not I’ll refer to “manny”.
THanks man