Midi Note Issue - Overlapping Notes

I’m sending midi to Cubase 6.0.7 (32bit) via an Alesis Trigger iO (via e-drum kit). When I record, the midi notes are doubling (overlapping), virtually right on top of each other (the second note only milliseconds behind and at the same velocity) . This is universal for all Notes and all Keys. I reset the Trigger iO to the default settings and it’s still doing it. Two questions:

  1. Is there a way to delete only the overlapping notes ? ( BTW - All velocitys are at 127 on purpose - I like to go in and manually “humanize” the end result).

  2. Can anyone come up with a solution in Cubase (Logical Editor?) to keep this from happening in the first place ?

Thank you so much in advance for any help !! CEH

Do NOT use ‘All MIDI Inputs’ as input for your MIDI track.

Jarno to the rescue…again !! Thank you my friend !! :slight_smile:. CrossEyedHenry