Midi note length

I’m having an issue with recording midi. I have a midi track with an output to Halion Sonis SE. The track records fine and playback is fine, but upon opening the Key Editor the notes I’ve played appear as long and continuous.

http://s1169.photobucket.com/albums/r512/MattGray75/?action=view&current=Miditrack.jpg

Have I overlooked a simple setting to fix this issue?

Have come across a solution (of sorts).

Under MIDI/Functions I selected ‘Legato’. This seemed to at least cut-off the note when another note was pressed. I am getting a lot of sustain on each note. Not sure if this is an issue with my midi keyboard or something I can change in Cubase.