Midi Note Numbers and Techniques and Actions

I’m not really sure how to describe my issue, but hopefully someone here might have some advice. I am trying to setup Spectrasonics Trillian Expression Maps. The have Gliss Up, Harmonics, Slide Up, Slide Down etc. set for specific Key switches. They are assigned to E1, F1, F#1, G1 etc… so that they stay out of the useable notes (open low E is E2 in Trillian). I’ve got them working fine with higher notes. The problem is that open E on the bass is triggered by an E2 within Trillian. I’m not quite sure where E2 is in Dorico’s staff, but it seems like it wants to be E1, so I can’t have it play the low E note because it is also a Keyswitch. How do I avoid all this. This is like a complex math problem for me. Of course I can transpose Trillian inside the software, I can also transpose my keyboard controller up or down as well.

Using MIDI monitor, I see that my controller is sending E2. Also, Trillian plays the low bass E with this E2. When I enter notes into Dorico using the controller, it places E2 in the staff (3rd space up). That is E3 in Trillians world. I thought E2 was supposed to be one ledger line below the Bass Clef staff? Is there a better way to approach this? What do I transpose? I want Dorico to place E2 one ledger line below the staff. If I transpose within Trillian, then the E1 conflicts with Trillians Keyswitches. I must be doing something dumb here, but I’m spending hours on this and it’s not very productive. Is there a simple answer?

I’m not familiar with Trillian, but bear in mind that as far as Dorico’s concerned, bass guitar notation transposes by an octave. If you play an E2 on your MIDI controller, it will be notated as E3, but Dorico is still internally thinking of it as E2. If Trillian’s not playing it as E2, you’ll need to tell Trillian to transpose down by an octave.

So if I play an E1 on my controller, it will be notated as E2, but Dorico is still thinking of it as E1. Trillian cannot play E1 as far as I can tell. I don’t get it. I’ve got some learning to do, maybe I’ll call Spectrasonics.

To add to the confusion, in Dorico middle C is C4, but some samples libraries call middle C C3. Check the Trillian documentation.

For setting keyswitches in expression maps etc you might be better off working in terms of midi note numbers instead of note names. Everything that uses MIDI thinks middle C is note 60, and the octaves below it are 48, 36, 24, 12, and 0.

Finally got it working! Thanks for the help. Here’s what I did in the hope that it might help others.

In the Trillian Expression Map, For “Natural Note” action, I set Transpose to +12 and now the staff plays as expected (Dorico is now sending an E2 to Trillian for an E1 staff note on the 1st ledger below the staff). Additionally, to get the Keyswitches to work, on each action like “Gliss Up” (which I created a new Gliss Up action specifically for Trillian) I had to also set the Transpose up +12 so that the Glissed note would be the correct pitch, BUT . . . then for the Keyswitch, I had to change it from E1 to E0 since it was also transposing and Trillian expects an E1.

Now everything works as I wanted.