MIDI Note On Not being recognised when switching Songs or Parts [1.1.65]

Hello, I’m evaluating VST Live with the 30-day trial version. I am running it on a Windows 11 Laptop (i7 processor). My MIDI controller is the Arturia KeyLab mkII 88. After creating Layers everything works fine. When I switch to a new Song or Part the new Layers respond to MIDI data. However, if I switch back to a previous Song or Part then there is no audio coming from the Layer. I switch Song or Part again and then back and it works - this is pretty repeatable.

MIDI Monitor is showing incoming Note On / Note Off information.
The MIDI Indicators on the Layer are not showing any activity when the issue occurs (they do when it is working)
One of the VST’s I use is Pianoteq 8 - if I open the VST and look at the MIDI data then it is only receiving Note Off messages - Note On messages are not getting through to the VST.
I can also confirm this behaviour with the included Halion SE VST - where I see the MIDI indicator is only flashing for Note Off and not Note On.
Other MIDI data appears to be getting through, e.g. sustain pedal controller.

Obviously this is quite frustrating in my evaluation as MIDI data is still being sent from my controller keyboard, but somehow Note On data is not getting to the VST. As a result I have to keep switching back and forth to get it working again. Obviously this would stop me trying out the application in any sort of live performance environment.

Did you try the “File/Preload” function?
Switching Parts or even Songs can take a long time, depending on how long plugins involved take to initialize. The preload function is supposed to “prepare” Parts and Songs to switch as quick as possible. Whether or not a plugin “forgets” MIDI Notes sent to it or not when not ready depends on the plugin(s). Try with other plugins to determine if it is up to those, or try with Preload run once? Maybe try “Preload Parts” which is even more thorough.
If it still fails, it would be important to know what keyboard you use to send Notes. After all, it is very unlikely that this is a common problem with VST Live, we wouldn’t have gotten away with that :slight_smile:
One more thing to try is “Help/Clean All User Data”.

Hi, File/Preload doesn’t make any difference to the problem. I have even tried with a minimum setup, i.e. 1 VST in either each part of each song and I have the same issue. It plays, I switch part (or song) and the new VST plays. I switch back to the first part (or song) and the original VST no longer plays. I have to switch to the second part / song and then back to the first and it works until I go through the above sequence and it stops again.

I’ve tried with Pianoteq, Halion, PadShop, Massive X and Arturia’s Piano V3 - and always have the same response.

Did you read my original post as I have provided a lot of information on what I am seeing - which doesn’t make sense as to what’s happening, as I don’t know the internal workings of VST Live. I will outline this again:

My MIDI controller is the Arturia KeyLab mkII 88. I use this extensively with other other applications, including other VST hosts and have no issue with these applications receiving and processing MIDI data, coming from the keyboard.

When I use VST Live’s MIDI Monitor viewer I always see all the MIDI data from my controller keyboard. It is always showing Note On and Note Off information - even when the VSTs are not making any sound. So does this not confirm that VST Live is receiving the MIDI information from my controller?

When I hear no sound I can observe the following:

The circles next to the MIDI Input fields on the Layer do not flash green when I press a note on the controller.

With Pianoteq I can see the MIDI data being received by the VST and this is only showing Note Off data - no Note On data.

I have done some further testing. I if I don’t use my sustain pedal (Roland DP-10), then I cannot replicate the issue. However, as soon as I use the sustain pedal on any of the VSTs in a Layer I get the issue.

What I cannot understand is why MIDI monitor is still showing all MIDI data coming from the controller - does this not suggest that VST Live is receiving the data? So why does Note On data stop being processed within the Layer and VSTs?

I am not implying this is a VST Live problem, but the layer within VST Live does appear to stop responding to MIDI data, even though MIDI Monitor is showing data. So something is not right in the MIDI signal chain.

I tried to reproduce the problem. The important hint was this:

When you change Parts while notes are still pending, the previous Part will continue to be active. A pressed sustain pedal also means notes are still pending. After all pending notes are released, the Part still remains active for as long of a time that the preferences Layers/Sustain Seconds (deafult: 0.5 sec) is set to.

This is important because when you have the pedal still pressed while going back to the Part that you switched from, this could be a problem, will check that.


Found it. I can reproduce it; if you hold the pedal down, or keep any notes pressed while switching to another Part, it will not accept any MIDI Input but Note Off commands and Sustain Pedal. That is correct (see above), but when you switch back while there are still pending notes, it should of course switch back to normal operation.

For now just make sure to release all notes and the sustain pedal before you switch back to the previous Part. Will of course fix it, thanks for reporting!

Unfortunately, we could not fix it for today’s “Friday version” 1.1.66, but it will be fixed in the next version, sorry for that.