Midi notes disappear if I press to early - Quantization?

When I am doing a new midi loop recording, I sometimes press the notes a bit too early and they do not appear at all once I am done.
I therefore try to press “late” instead but this is very uncomfortable.

In my previous versions of Cubase I never had this problem.

Is there a setting to change this behaviour? Perhaps a quantization during recording which “forces” only the first notes to sit at the right place?

Thanks for all replies.


Preferences > MIDI > Extend Playback Range of Notes that Start before the Part.

Hi Martin, I have Cubase Pro 10.0.4, and can’t see this option. Is it new to Cubase?
It’s not only when playing the first note early, but even when it’s a few ticks after beat 1 (which, as Smokey Joe says, feels unnatural), it still doesn’t record for me. In the past, I’ve been advised to put an empty bar first, which is a poor work-around. I’ve also been advised to alter the buffer settings. Any other suggestions?



See attached screenshot, please.