Midi Notes early (or audio is played early)

Thanks, will try. Do you have System Timestamp for Windows MIDI Inputs on or off?

Unfortunately, this did not work for me either. :cry:

I have them on.

Did your topic get (dis)approved?

I received an email notification of approval but somehow the topic was placed in general and not issues.

Alright, I’ll give it a shot of my own then tomorrow.

EDIT: Actually, I won’t. This stuff is bad for my blood pressure. :stuck_out_tongue: I’m trading Cubase for Studio One Pro 3. Maybe I’ll be back someday when things are looking better.

I’ve been a long long time steinberg user and die hard fan. Cubase SX3 days - through Nuendo 4 to Cubase 5 - Cubase 6.5 - to Cubase 7.5 - then on to 8 Pro as a demo recently. I’m fluent in many DAW’s as we all should be these days (Avid Poser Tools - Studio One - Ableton Live - Reaper - you name it, etc.) - and I tell you Cubase just owns the lot. Always come back to it. Nothing compares to its Midi prowess, shortcuts, or logical navigation control, modern sexiness (8 sure looks good), and quick editing on the arranger page. Nothing. I never felt the need to chime in and have long long shadowed in this forum just to learn so much from so many of you users over the years as an anonymous guest, but this topic touches something very real and should remain elevated to ALL USERS and Steinberg Developer staff. I’m happy to see others posting on this in 2015 - and posting RECENT CURRENT.

Midi Notes in Cubase Pro8 are in fact recorded early irrespective of actual time - no matter what you do. No matter what setting or preference, or checkbox, no matter what latency on your card, no matter what Latency Compensate Button is pushed on the track itself, no matter what Midi interface or protocol be it Midi over Lan - Midi over Firewire - Midi over PCI slot direct to the motherboard or Midi over USB from a dedicated software driver. I have done extensive elongated tests on this matter as a freak with obsessive compulsive tendencies and have seen this as a major issue in ALL newer cubase versions.

I’ve extensively tested multiple scenarios and physical loop back tests that remove the human compensation error out of the equation COMPLETELY (the tendency to play a note ahead of time due to VSTi sound card delay latency). Notes appear on the grid in some of these tests before the note should have even left the original sending interface. And this is not a human playing the original source note. These are hard quantized drawn in notes in the midi editor from the master. A total impossibility occurs every time in Cubase 8. Cubase is pulling the notes forward during recording - regardless of timestamps or the sources being external or internal clocked.

tomorrow I plan on taking screen shots of the tests I’ve done which include:
-Syncing Cubase 8 Pro master to Cubase 8 Pro slave between two seperate PC machines’ on a render farm slaved to motion picture MTC (midi timecode) over giga 1000mbs ethernet RTPMidi
-physical hardware loopback tests from midi interface (In to Out) Different Host PC - Different Clock
-physical hardware loopback tests from same midi interface (In to Out) Same Host PC - Same Clock
-physical hardware loopback tests from seperate midi interfaces (In to Out - between two different Midi intefaces) on Same Host PC - Same Clock
Cubase Timestamp checkbox On/Off
Cubase Activate Midi Latency Compensation button on/off Midi Track itself
Cubase Compensation button in toolbar On/Off
Comparisons between Cubase Pro 8 and old dinosaur Legacy Nuendo 4.3 32bit (which btw NUENDO 4 does NOT pull notes forward whatsoever - it places them slightly behind the grid exactly where they would be in real world application despite NOT featuring what Cubase Pro 8 supposedly fixes with a Latency Compensation button on the track.
Comparisons between Studio One V3 and Cubase Pro 8 using all of the above EXACT same methodologies and exacting battery tests. (of which Studio One Displays Midi Notes not before the grid, but after just like Nuendo 4.)

In addition its more than just Cubase Pro 8’s tendency to pull forward EVERY SINGLE NOTE it also induces test repeatable jitter and inaccurate placements of random notes singular. Meaning, the occasional note will be pulled forward much more than a adjacent notes or a measure before it - This tends to lead to thinking you played sloppy - but its not actuality indicative of your true performance. THAT’S HUGE!!! These errors directly influence workflow by endless fixing and nudging, and perceived accuracy of a recorded track that may otherwise be flawless. Steinberg you are the kings of Midi - how has this defective code made it into your current offerings.

These tests and the remarks from others on this forum - in multiple threads for years and years all the way into 2015 identify an issue that Steinberg needs to account for. Midi is early - in circumstances where its ABSOLUTELY impossible for the notes to have reached the recording machine before the source even sent it. Timestamps in Cubase Pro 8 are jittery in addition to being pulled forward. Something in the coding has changed from the legacy platform for midi-accuracy and precision- My nuendo tests blew me away. It is indisputable and I hope Steinberg takes action. You guys out there - the user community, please keep this thread going, elevate it, and if anything, push to have this placed in a dedicated OFFICIAL ISSUE’s to be fixed submission. Its real. Absolute.

Over the years I have used the logical editor with a quick macro to nudge my notes behind the grid after recording, then iterative quanize if needed. Its a guess nudge of a few ticks BACK IN TIME with the logical editor - and an estimate at best. As Cubase Midi timing is showing to be totally VARIABLE at times. The work around gets me by, and I always thought it was me, but tests show a greater breakage at work here - and its not me the musician who is jumping ahead of the grid - or the cause of that sloppy note - More often than not - its actually Cubase Pro 8 doing it.

I will post pictures and screenshots tomorrow. Thanks to the guys who are posting on this particular matter - you’re doing a good good thing. - We all want this amazing software package to be what it totally can be. The king of the hill. -

Ryan

BTW - I’m running Windows 7 64bit 8gb - SSD’s and Phenom 6 core Overclocked 3.2ghz and Nivida 660 Extreme Ti 2gb Graphics. Identical On 3 seperate VE Pro5 Render Farm DAW’s linked via Gigabit Ethernet Switch - Audio Interface Zed R16 Firewire and an Maudio 192 PCI Card Interface and Midi and Audio - Korg Pad Kontrol external Midi via usb - RTPmidi Lan.

In all those years I always thought that my timing was horribly bad. Now I know it is not me, it is Cubase. It is nearly impossible to play along with the click and record the MIDI notes exactly on the grid. They are always too early - with one exception: the first note in the first bar (if the left locator is locked to a bar) is often on the first beat.

I have also seen another strange behaviour:
I started an empty project and added an instrument channel with EZ Drummer. Then I routed the output of the instrument to a group, added an audio channel with this the group as an input and recoded both MIDI and audio.
With my system I have an ASIO-in latency of about 7 ms. When I set “ASIO latency compensation” to on I would expect that the MIDI and audio event would be coincident. But I found that audio is more than 20 ms late. When I set ASIO latency compensation” to off, I would expect a difference of 7 ms (latency) but the audio is about 27 ms earlier than MIDI.
I measured these differences between audio and MIDI with ASIO guard off. They are slightly smaller when ASIO guard is on.
So what is this compensation calculation for? No matter if it’s on or off, the timing between audio and MIDI is horrible.

So Digital Performer has the best midi timing?

I had a similar problem with my USB Midiman (M-Audio 2x2) connected to a Roland XV. When playing back, the audio from the Roland was ahead of the midi data in cubase. Very strange. It took a while but I fixed it.

Under Devices -> Device Setup
I enabled ‘Windows MIDI Out’ for the M-Audio 2x2 interface’ and disabled the ‘DirectMusic Outs’ for this device.

Then in the project audio part just selected the M-Audio output and no more delay. Midi plays in time.

This worked for me anyway. Hope it helps others.

Ran your test and I have the same issue! I’ve always noticed that “retrospective record” captured my midi WAY early, but I didn’t realize this was the case for ALL MIDI RECORDING!!! I really hope they take this seriously and offer a fix. I dont mind paying for it as an 8.5 update - thats how important it is!!

Can whoever reported this please post a link to the thread here so we can add our +1? Its important we show Steinberg this is a major issue!

Here’s the link- http://www.steinberg.net/forums/viewtopic.php?f=231&t=80800
Steinberg still hasn’t moved it to Confirmed Issues, which is surprising to me. I can’t imagine that accurate timing wouldn’t be a very high priority for a DAW.

According to my tests, yes, it was. I tested Cubase, Logic, and Digital Performer. Latest versions. DP was by far the most accurate. I didn’t test StudioOne because it doesn’t have notation, which is a non-starter for me. I didn’t test ProTools because they’ve gone to a subscription model, which also disqualifies.

I have switched to DP9 for the time being. There are many, many things I will miss from Cubase, but always feeling unsettled about timing is not one of them. I will be back when this issue is sorted, most likely.

It has been moved to “collected issues” which means its been confirmed. Hopefully a fix is in the works!

WELL… I will also chime in to say. I won’t be purchasing 8 until I hear some kind of why we are doing it wrong from Steinberg.

This is definitely the most important issue for me. I have noticed this in the passed but dismissed it as not having things set up properly. Will try the SOS article.

not sure if this is the issue…

goto:
Devices > Device Setup > (look for) VST Audio System

there is a check box Adjust for Record Latency - UNCHECK

hopefully this may help… cheers!!!

I tried that. Problem with 8 is the consistency of the notes timing varies, In 5 it is fixed (same delay with each note), when I did the tests recommended in the SOS article. So in 5 easy work around with delays/offset. 8 has a kind of unintentional swing.

As small consolation, please note these issues have been taken up by Steinberg:

http://www.steinberg.net/forums/viewtopic.php?f=231&t=80800

http://www.steinberg.net/forums/viewtopic.php?f=231&t=82639

Any idea why those threads got locked before people discussed possible solutions.

I’m sticking with cubase 5 as the difference stays consistent, easy work around. 8 is like unintended swing on my system after trying the demo. No upgrade coin from me.

There was plenty discussion on both, but I guess once Steinberg “acknowledges” the problem, that part is deleted, because there were no solutions. Steinberg has to fix it.