Midi Notes early (or audio is played early)

Midi Notes arriving early, or I’m hearing all audio early.

Hello, all. When recording midi, the notes are placed earlier than played.
I’ve had this problem in Cubase 7. I hoped the jump to Cubase 8 would fix it, but it remains. I’ve looked extensively online, but most forums trail off being unsolved, or people just recommend turning on System Timestamp. (Which had no effect). But I do arrive here having done tests.

Test

  1. Add a midi track pointed at Halion (sound with a sharp attack)
  2. Add a group track
  3. Change Halion output to group 1
  4. Add an audio track with “Group 1” as its input.
  5. Enable both tracks and record. Match the metronomes click.

Zooming in to both the waveform and midi notes, the midi is placed early. When played back, the midi will be slightly ahead of the metronome. The audio file is placed correctly as played.
Also, just to prove that the tracks don’t agree. With that same setup, if the audio track is monitored, there will be a slight phasing (as expected, hearing the notes doubled) while recording. But playback (monitoring disabled) changes that phasing into a hard flam.
A rendering of the midi track, will put the audio in the exact incorrect spot. Also, A re-rerecording of the group track (with the incorrectly timed midi) will create audio in the incorrect spot.

Could I be hearing ALL audio earlier than Cubase thinks I am? When recording audio, I need to adjust for Record Latency (about -700 samples) for accurate timing from an external analogue source. The above test were performed with and without that enabled, but made no difference. If there’s a comparable adjustment for midi, PLEASE point me towards it.

I’ve tried resetting the midi port filters, testing with and without Constrain Delay Compensation, moving the “Ignore port filter”, and ticking the ASIO Latency Compensation box. None of these had any effect.


I’ve been battling this for a great deal of time, ANY help, or anything you think I should try, would be appreciated. While the incorrect timing may be slight, it builds and builds while playing to a previous track. This also occurs when playing to a quantized part or loop, not just the metronome.



Windows 7 Professional
Intel i7-4770 @3.4 Ghz
12gb Ram
Cubase 8.05
Ur28m-Yamaha Steinberg ASIO
Yamaha Motif XS

Hi, I see from your spec that you are working with a Yamaha Motif XS. If your issues are in conjunction with the VST-Editor Version, this is a known issue and yamaha/Steinberg are working on it!

There are tips for Workarounds in this Forum (which lead to not using the vst, but the stand alone Editor Version).

Cheers, Ernst

Yep, aware of that. Thanks, though! I’m just using the Yamaha midi input. Also, I’ve hooked it up as an External Instrument. Same results.
It was apparent in Cubase 7, also. I’ve just now decided I’ve had enough of manually dragging the notes to the approximate location.
I figured that my setup is all “Team Steinberg”, there shouldn’t be any issue.

Hello All. I’m not going to let this one die! I would be VERY thankful if someone could repeat these steps, or explain how my logic is incorrect.

Test

  1. Add a midi track pointed at Halion (sound with a sharp attack)
  2. Add a group track
  3. Change Halion output to group 1
  4. Add 2 audio tracks with “Group 1” as its input.
  5. Enable both the midi and one of the group tracks and record. Match the metronomes click.
    For me. The Live Audio is placed perfectly.
  6. Enable the 2nd Group track and record the audio from the recorded midi.

It’s very slight, but doesn’t match for me. If it was some sort of delay in the soft synth, I would assume it would be recreated on the second pass. It leads me to conclude that the problem is Cubase incorrectly placing where the midi is recorded.

Hi - are you sure?

Your Picture - if I get it right - Shows to me that the live Audio is LATE and the recorded one is perfectly ok.

Half right. When recording, the “Group Recorded Live” track is exactly where I played it. The Midi is placed slightly ahead. The 2nd pass, recording the midi, puts it in the exact spot of the midi, unfortunately that’s the wrong spot.

i fully understand the issue at hand. we have debated the issue endlessly since cubase 5, at least.

all manner of tests performed and all report inconsistancies when scrutinized closely.

many report none but likely are getting them but just dont know, or they are small enough to be irrelevant for the job at hand.

anywhere between 2 to 40 ms variation, although the variation tends to be variable but still somewhat random.

many have given up long ago or switched to other daw which dont show this errors on the exact same system.

This is a well known issue that Steinberg is refusing to fix, i have posted a video that clearly shows the problem here:

https://www.youtube.com/watch?v=O2HXNQP2iwE

I guess that after waiting for 4 major releases for this issue to be fixed, its time to switch to a different DAW.

One thing is for sure, Cubase is the ONLY daw in the market with this kind of tremendous bug being ignored for more than 6 versions.
Just a simple google search, or even a search on this forum will show you that the problem exists since at least SX.

1 Like

It would be better to post this in Issue Reports:

http://www.steinberg.net/forums/viewforum.php?f=230

Make sure to read the guideline for posting there.




This is what I end up with when I replicate your steps:




EDIT: It’s directly related to the buffer size set in the ASIO driver.

Tested with both ASIO4ALL and Generic ASIO Driver. (Don’t have access to my C1 right now)

I don’t have this issue, not that it matters. But if “they” are not able to reproduce it there is not going to be any fix. Years ago I have had a similar problem, that turned out to be the audio driver reporting the wrong latency, a driver update took care of that.

I had been feeling uneasy about midi timing and decided to check its reliability. I have the early midi problem as it turns out. I recorded quarter notes and quantized them 100% and ran that track into another midi track via an iac bus. Sure enough, everything was recorded early in the second track. How much early was dependent on buffer size.
I did the same test in Digital Performer 8 and Logic X. DP was not early, but Logic was, so the plot thickens.

Steinberg- let me know it you would like me to send you the projects to verify. This seems to be an issue worth resolving.

I wonder if this really is setup dependent like you say, because I reproduced it with two different drivers.

Could you please go through the reproduction steps and screenshot the result? (High buffer size like 2048 samples is preferable to clearly show the impact.)

Should I post this as a bug/issue report? There are clear reproduction steps.

Probably a good idea, but I can’t imagine they aren’t aware of the issue. For the time being it bothers me enough that I’m using another DAW for midi, which is a shame because nothing compares with C8’s midi features.

Just got the time to test it, and sorry can not reproduce the timing issues. But a few questions just to be clear. Are there any plugin fx on the group track or audio track, and what happens if you instead of the group track use a dummy Bus. (A output Bus that is not connected in the VST connections, and used as input for the audio track). Is auto Quantize on ?

Easiest reproduction:

  1. Set the cursor to bar 2
  2. Turn on precount
  3. Record a note on the first tick
    -> You will see that it has placed the note before the cursor.

(Buffer sizes of 64 and 2048 samples.)

Tested on two systems using ASIO4ALL v2, Generic Low Latency Audio Driver or Yamaha Steinberg USB ASIO driver, with ASIOGuard and Mult-Processing on or off.

I get similar results on my system. This is a BIG DEAL and really needs to be fixed. Please!!! I’m using an Apollo Quad BTW.

Post your audio card settings with these.
ASIO Guard, buffer, Multiprocessing, Adjust for buffer size…etc.

:nerd:

I’ve tried every combination of settings I can think of. Different buffer sizes, multi processing on and off, ASIO guard on and off, different audio interface drivers- it’s all early. Frustrating!

I can imagine… I have the same issue with MIDI and trying to solve it…

It almost seems as Cubase is becoming super clumsy. Seems like they break something, fix it and break something else then fix it and the 1st break comes back…lol