Midi Notes Not Allowing Me To Change Length In Key Editor (Cubase Pro 12)

Hello there,

i hope i can tell you my issue in a way you guys know what i mean… so i was working in the key editor drawing some midi notes for an instrument, however going down to a certain size, those midi notes won’t go smaller via Quantize Preset Grids… so even though the quantize preset is set to 1/64, notes won’t let me make them fit this size, they stay larger no matter what i do… So i tried out which sizes still work and came to the conclusion that my midi notes won’t go smaller than 1/16, everything smaller stays 1/16… this worked just fine in C11 so i assume this is some kind of software bug?!

Did some of you have the same issue since C12 or even know how to fix this? Simply restarting c12 didn’t help. Only way to do so was free drag of the notes via the size/length display… but its a very inefficient workaround…

Thanks

You maybe have a Length Quantize selected, it’s set independently from the note start quantize.
If you set it to Quantize Link, it is always the same as the quantize.
image

In case you don’t see the option, right click anywhere on the bar or the cogwheel all to the right and tick length quantize, it should show up then.

You always can deactivate grid lock by pressing [J] or temporarily by pressing the control key while positioning with the mouse.

Instead of dragging or mouse-wheeling the position values in the left of the bar, you can also click and enter values with the keyboard, for instance click the right value, enter 0, 30, 60 or 90 and hit the enter key to align it to a 1/64 grid position.

image

Those are my favourite options for precise positioning, it works faster and more reliable for me than changing the grid to very small values sometimes.

Cheers

2 Likes

thank you!