Midi notes played early

Hi. I’ve had a problem with Cubase for years and I’ve never been able to resolve it - Midi notes being recorded EARLY.

I just figured it was due to my MOTU 896mk3. I’ve gone through various computers and finally got an Apollo Twin. Same problem! ACK! Tried different midi controllers, still the same.

I do mostly audio so it’s never really been too big of an issue but I’m writing some MIDI music and it’s killing me! My timing is just fine as it all goes back in sync when I manually shift everything over. It’s been an issue from Cubase 5 to 10.

Windows / Alienware Aurora R7 / SSD / 32 gigs ram / Apollo Twin.

Thank you for your help.

Hi,
Which MIDI settings are you using?
(studio > studio setup > MIDI Port Setup, maybe post a screenshot of that)

There are various causes of this.
Firstly check you’ve not got any plugins bypassed whilst recording your MIDI, they should be either deactivated or on.

Hi. Thank you :slight_smile:

https://i.ibb.co/xL3nG6w/Capture2.png

there are also MIDI settings in preferences.

Thanks for the image.
Try ticking ‘Use system timestamp for Windows MIDI inputs’