Midi notes recorded too early!


I am using Cubase 11 pro.

My problem: When recording to the metronome with my guitar, everything is just fine on beat. When recording with midi instruments (Roland A49 and Launchpad Pro) it seems to be fine on my headphones, but in the piano roll it shows that the notes are placed too early. I downloaded reaper to see if I myself is the problem, but it´s not. Unfortunately.

This is my guitar recording:

This is my midi input recording! Way too early.
See post #2 (sorry, as a new user I am only allowed one picture per post)

And this is my reaper check… all good here.
See post #3

I have tried almost everything, starting with all latency compensation settings and ending with pushing this little buddy.
See post #4…!11

I am using a Win10 machine. These are my settings. Changing them did not solve the problem in any way.
See post #5…!11plskillme

Do you have an idea?? This is unacceptable for me. If only an update to Cubase13 would solve the problem, i´d do the freaking update. But I am too afraid that I´d be spending much money for absolutely nothing, when the problem can´t be solved that way.

Also that problem doesn´t seem too uncommon through many versions, as my research did tell me. Unfortunately only few of them were solved, others probably… switched to other DAW´s ? :smiley:

Please, tell me this is solvable. Thanks in advance!

Midi input recording too early

Reaper? All good!..

Pushing the magic button? No help.


These are my settings.

There is a MIDI offset value in the inspector, that’s not been set to a non zero value has it?

Also, if you’re on windows there’s options in the MIDI port setup page to use system timestamp, try that if you’re having problems. Detailed in the manual:

1 Like

Thanks for your fast reply! Unfortunately no, the inspector is set to 0 and the system timestamp hasn´t changed any.

But I found this out:
I run on 256 samples. Latency shown around 5ms, but I know this isn´t the real value. Some time back then I measured the latency and came around real 10ms.
When I change to 64 samples, my problem gets way better, almost solved. Sadly I can´t run on 64 samples, it´s too much to do serious recording as it gets unstable. And please keep in mind that my analog recording is just fine, midi only is affected by this strange behaviour. I use a ESI Maya044ex… maybe this is the problem?