MIDI parts automatically writing over other sections

Never had this issue before but it’s coming up more and not sure why, since I’ve always used the same process.

Dealing with a VST Instrument track with a MIDI keyboard. Let’s say I record an intro on that channel, stop recording, and go to the end to record an outro. I’ll record this outro on the same channel but as a new segment entirely from the intro. After the outro is recorded, the outro segment automatically spans the entire length of the track, covering up the intro completely, and only shows the outro – even though they are in separate sections and don’t temporally overlap.

Usually they just appear as separate sections and I can glue at will. I’ve looked into the lanes dropdown and don’t see the old sections (the intro in this example) when they are covered up.


Do you record to the Editor by any chance? Which window is in focus, when you record the outdo, please?

Not that I know of. I hit Record Enable then recorded, with the main project window and transport panel open and up front.


If you click the Record button on the Transport Bar, the focus is definitely in the Project window.

Could you make a video screen recording, please? Maybe we will see something more. Thanks.

I couldn’t make a video screen recording but here are two screenshots, before and after.


Could you try in Cubase Safe Start Mode, please?

What MIDI Recording Mode do you use, please?

It was the MIDI Recording Mode! Never knew about that and not sure how it got switched. Thanks @Martin.Jirsak!