Midi pitch


I am having some problems with the pitch of my midi being out. it is sharp by about 4 cents and I can’t quite work out what it is, or how to fix it. I was wondering why everything I did with keys was just sounding a little out as I just imagined that the midi would be set to 440hz. My casio keyboard is also out by the same amount surprisingly but there are times when I just write the notes in manually and not use a midi keyboard just the editor tool and these are also out. Can i fix this in midi or do I have to try and pitch shift the wave file afterwards? Which I’ve also seemingly had an issue with as it doesn’t seem to want to pitch it down by -4 cents.

Any assistance will be appreciated.



How are you measuring this?

Anyway, from what you’re saying, your Casio is producing the sound and probably has a tuning adjustment, It’s got nothing to do with midi.

What instrument are you triggering with midi?
Check if there’s no pitchbend data being recorded, maybe your pitchbend wheel is not centered?

to the OP, do you get the same result when using one of the Steinberg VST instruments to produce the sound? (I should have asked that before… :blush: )

To measure the pitch I am using a single note and running it from my amp through my boss guitar tuner pedal. I have done the same with my Keyboard. My pitchbend wheel is centered. i have a Casio Px-3 I have written to casio to fix this because I have found that I can move the pitch down by -4 cents and it comes in tune, although only from C2 to C6 lower than the c2 and it’s getting flat, higher than the C6 and it’s getting sharp again. (Almost like a real piano) They have provided me with instructions on how to reset this and keep it (currently everytime I turn the keyboard on I have to shift it -4 cents).

As for the actual sounds, I don’t often use the Steinberg VST sounds I mainly use Komplete. I chose a plain sound to test this on, just a single piano note because some digital tunes using polyrhythms etc you couldn’t really get a reliable tuning off. I figure once I have sorted out whatever is causing the pitch issue is sorted all of the sounds will then be ‘in pitch’ -4 cents isn’t much but when all the guitars and bass are set to 440Hz and the keys are at 444Hz it just doesn’t quite sound right as you can imagine.

I will test whether shifting the Keyboard down and then plugging it into the midi changes the sound in the midi editor. If so I will post this as the fix and just have to go back over all the midi sections and re-add in a note with the keyboard midi at the right Hz.

If it hasn’t fixed the problem I’m not sure where to from there. Guess I’ll find out this weekend once I’ve road tested the above.

Thanks everyone for your replies


What does your Boss Guitar Tuner pedal show, if you use Cubase’s own “TestGenerator” plugin (in the “Tools” subfolder… it has a setting for A440)?

It shows the note to be sharp by a few cents - I’ll have a look at the testgenerator and see what it states. By ear though something didn’t sound right and it really showed up in a rehearsal where I used the keyboard for live purposes. That’s what made me go in and check the midi in the recordings.

I will post the results here by the end of the weekend. Thanks again