MIDI Problems with Windows 7


I couldn’t see where else to place this! I’m curious to know if anybody else has spotted any problems with Windows 7 and MIDI, and specifically the reception of MIDI Clock causing Windows 7 to have problems when also receiving SYSEX dumps.

I think it’s also worth people being aware of this issue! Even if I can’t find fellow sufferers!

I have a strange problem when trying to receive SYSEX bulk dumps from my Yamaha EX5 synth (an awesome beast and one of Yamaha’s finest!).

I create my own Java librarians for different synths (over at www.xfactory-librarians.co.uk), and one of my users spotted this problem. When trying to import SYSEX data from the EX5 using “ex.factory” he was getting Time-out errors. It all works fine on XP. I missed the problem first on Windows 7 because the EX5 has two sets of MIDI Ports and for reasons to do with my live setup and how I have MIDI A configured I use the MIDI B port to output data. SYSEX Data transmitted on this port is not lost. My user was using MIDI A to transmit the SYSEX data from the EX5 to the PC and he was not receiving data.

I have verified that this is not a problem with my librarian or Java MIDI, because I get exactly the same problem if I use the wonderful MIDI-OX to manually request a SYSEX dump; it also times out (and works on XP!).

The behaviour is the same using different PC MIDI interfaces as well, so that rules out hardware and a vendor driver issue.

Anyway, I started looking for differences between my EX5 MIDI A and MIDI B outputs, and I never realised that its MIDI A Output by default sends out MIDI Clock Messages in addition to running status. I saw this when using MIDI-OX’s low level input monitor.

So, if I set the EX5 to external sync so that it stops sending MIDI Clock, then Windows 7 quite happily imports SYSEX data from the EX5 MIDI A output with no time-outs, which verifies that it’s an issue with Windows 7 and MIDI Clock.

With MIDI Clock on the EX5 active again, I messed about with different MIDI buffer sizes in MIDI-OX and with very small buffers, I managed to get partial reception of SYSEX messages which were the length of a single buffer, but never a full message.

I’ve trying googling for the issue but haven’t found anything of relevance.

So has anybody else seen this?

I haven’t, but I don’t own the hardware in question.

Have you tried it with different MIDI interfaces to your computer? I’m suggesting this to eliminate the audio interface drivers that you’re using.

Hi, as I said in my post above, I’ve tried it on two different interfaces :slight_smile: A MOTU MIDI Express 128 USB Interface and an EMU 1212M PCI interface. And the user who report the problem is using a Focusrite Saffire PRO 24 DSP Firewire interface.

So, I don’t think it’s a vendor driver issue.

Have some suggestions, but you don’t mention a Cubase version and didn’t post in a specific forum so we could play guessing games all day.

If Cubase is not receiving sysex it’s because the svsex filter in Preferences is turned ON by default so none will get through. Turn this off.


I don’t mention a Cubase version, as I haven’t had this problem in Cubase. :slight_smile: I’m just posting the issue I’ve found in a few forums that I use to see if I can find other people with the same problem and to see if Windows needs configuring to avoid this, or of nothing else to make other people aware of it.

So I posted in a general forum over here as it’s a general issue and not specific to Cubase, and I figured there might be a few MIDI users here. :wink:

For completeness, I am a Cubase 6.05 user on Windows 7 Home Premium 64 with the latest updates on an AMD Athlon 6000+ system with 4GB memory, using EMU1212M and MOTU MIDI Express 128 midi interfaces.

Sorry. I obviously missed that.


I thought I’d resurrect my old thread on Windoze MIDI issues. I never did find an answer to the issue described above, but I now have another one that I’ve encountered with the Yamaha SY77/99 Range, but of course, I think it’s a Windows 7 MIDI issue.

I discovered this one, having recently acquired a Yamaha SY99 (awesome synth!), and was updating sy.factory MIDI support to cover this. Whilst Voice SYSEX MIDI transfers were working fine, if I tried to get SYSEX dumps of the sequencer data, they were failing.

Again, I verified that MIDIOX is also seeing the same problem. In this case it looks like a buffer size problem. If the data doesn’t fit in what is probably an internal Windoze 7 MIDI buffer, you don’t get all the data.

I rebooted the PC back to Windows XP and all is working fine on that. Also since posting the original question, I’ve acquired an iMAC, and all the SY99 data transfers are working fine on OSX.

So it looks like Windows 7 is not a good platform for MIDI for those of us with older synths that still need supporting. Whilst the world does indeed move one, its not always for the better, and these older synths are more “interesting” than later ones, so I’ll always have my classics. Looks like I’ll need to keep a "classic: PC running XP as well! :open_mouth:

Hi Derek,

I can confirm these Problems for two Yamaha Devices more: the TG77 and a 02R. “Big” Dumps, such as Bulk Dumps of the TG77 and unfortunately the Scene-Dumps of the 02R are something like scrambled by the WIndows 7 64-bit Midi system.

Under XP the same here: go, Win7 : no go.

Tried it with Cubase 5, 6, 7, 8 and Sounddiver. It´s a problem of Win7. For the TG 77 it helps in Sounddiver to
increase the timeout - tolerance.

Something in the Win7 Midi-Buffer size must be misdesigned. And: Yamaha did once what is lethal now. As I always
used to backup my 02R Projects I fear I have to replace the 02R (or should go work without an external console).

The oldest Roland from 1986 (MKS50, D-550) works fine. And of course the modern stuff like Integra 7 or GR55 (And these Bulks are huge). So I don´t just blame Windows but also Yamaha! What the hell did they include?