MIDI punch in doesn't overwrite previous take

Hi all,

Not sure if this issue occurred prior to Cubase 9.5.10 (my current version). I searched for the keywords MIDI punch and didn’t find this issue listed.

I find that punch in-out activates recording, but for MIDI tracks, the playback data is combined rather than replaced

Steps to reproduce:

  1. Open a new project. I used a customized Piano+Vocal template (I had issues with the existing template in 9.5 so I built one from scratch)
    a. On track 1: MIDI instrument (e.g. Yamaha S90ES piano)
    b. On track 2: audio track (e.g. Mic input)

  2. Record enable both tracks and activate monitoring.

  3. Record a take of piano + vocal.

  4. Set locators for punch in/out points.

  5. Activate punch IN only.

  6. Ensure both tracks are record-enabled, and activate monitoring.

  7. Set playback from a bar or two before the locators and start playback. Play and sing along with the recording. Note: You won’t be able to hear the audio track due to monitor being enabled.

  8. When punch IN point is reached, the MIDI and audio start recording.

RESULT: A new MIDI part is created at the punch IN point, but played at the same time as the original recording.

NOTES: MIDI normal recording and cycle recording doesn’t offer the option to NOT overlap MIDI data on a single track.

Is there a way to set later recordings to play instead of the original recordings, but keep the original recording as a backup?

Ah crap. User failure. Set MIDI recording mode to “Replace” and I get what I want. It’s just not clearly defined in the text. No worries.