Midi record last events?

I didn’t know how to search for this in the manual, but is there a ‘midi-recall’ button I could press that would reveal/display/pop-up the most recent midi events in a track, if I didn’t hit record?

I.e. Im playing along on a piano track and trying a few different phrases against the rhythm. I am not recording because I have looped an 8-bar section that I am just jamming to to flesh out a line. But when I find that perfect line and don’t want to arm to record and try to recapture it, I should be able to just click a button that can recall the last thing I did in a midi track.

Anyone know what Im talking about?

You’ re talking about retrospective record.

Yes. You set this up in Prefs->Record->MIDI. I have mine set to 10000 events, just to be on the safe side. Now go into Key Commands->Preferences->MIDI - Retrospective Record and set yourself up something convenient.
[Edit: sorry, my mistake, you want Key Commands->Transport->Retrospective Record]

Now set up a MIDI track, make sure it’s picking up the input, and Record Enable it. If you forget, nothing goes into the RR buffer!

Finally, if you’re free-playing I suggest you set the track to Linear Timebase, which it probably won’t be by default, to preserve your timings.

I have all this set up as a template. It works really well.

Perfect, thank you! Exactly what I was looking for.

I would have hoped there was a button on the project bar or something, so I could remind myself of what the key command is, but this is great anyways.

How do I set up my track for Linear Timebase? I couldn’t find that nor in the manual search.

Uhhmm…I set the KC to ‘G’ so after I played a few rounds on a loop, I pressed ‘G’ and all that did was “De-Activate Retrospect Record” and “Activate”. It didn’t actually put up a midi region with notes in it.

Maybe I missunderstood, but isn’t it so that I should then be able to press ‘G’ and my notes come up?

Did you press stop before you pressed G? I ask because I’ve just noticed some behaviour I was unaware of. If Play is engaged, pressing the RR key gives an empty buffer error. I’m on Windows so I wonder if the messages you’re getting are the Mac equivalent. If you press Stop first, you should get loops arranged in lanes.

Normally I use RR with play stopped. In this case I’ve noticed that the event displays differently, according to whether you’ve got the Loop on/off:

  • if on, the event only goes to the end of the loop. The remaining events are there if you drag the event out but you don’t get events in lanes.

  • if off, you get a full event, extending beyond the loop.

Finally, the Timebase button is the one on the track header that usually defaults to an orange crotchet (which you may call a quarter-note, depending on where you’re from). With this set, your notes will be tied to bar positions so if you change tempo they will move accordingly. This may be what you want, of course.

If you record free-playing, as I’m usually doing, I’ve found it necessary to click this orange button to get a grey clock. This is Linear Timebase and notes are now tied to time, so your playing is preserved regardless of the tempo. Now you’re in a position to set the tempo later (or create a tempo map) to fit your playing and build the track up from there.

Yes, you misunderstood.

Thanks, thinkingcap. You mind telling me how to use it then?

  1. I went to Preferences > Record > MIDI and activated RR and 100000 was already set as default.
  2. I then set a KC to ‘G’.

I press play and let my track play back while I play on an instrument. Then I press stop and press my key command ‘G’ and get nothing.

Yes Crotchety, I pressed stop before I pressed ‘G’. In Logic Pro also I usually stop before press the ‘recall’ button.

You’ve got the track record enabled, haven’t you? It won’t work unless you have.

Sorry, gotta hit the hay, hope you sort it. I’ll check back tomorrow.

yes, it was record enabled too. Nothing comes up.

All I get is a note saying RR de-/activated.

Hmmm. Maybe it’s different on Mac. Just to cut variables out, why not try it with playback stopped, tinkle some notes and then activate RR from the menu.

Yes, that worked, thanks.

I figured out the problem. There are two KC’s you can set for RR. I only found the one in the MIDI section that activates it. The one I should have set a KC to is in the Transport section. There was already a KC set and is ‘shift’ + *.

I would still like to see a button I could have on the Transport bar or Project bar.

But this is plenty helpful.

Thanks for helping me sort this out. Two brains are better than one!

Sorry about that, my mistake, should have listened to the little voice! I’ve edited the offending post. Glad you’ve got it sorted out. C