midi recording ahead of time

Hi guys
when i’m playing my midi in time with the beat the data is recording before the bars which is annoying me.

in my midi preferences i have

Record-enable - on
snap midi parts to bars - on
solo record midi editors - on
100ms Midi record catch range in ms

retrospective record - on
10000 events Retrospective record buffer size

ASIO Latency compensation active by default - on

Replace recording in editors - none


Can anyone help me it is driving me in-sain

thanks

Have you ticked the ‘use system timestamp…’ options

+1

I had the same problem and that fixed it straight away! Not sure why that option isn’t automatically checked TBH, maybe I’m missing something…

hi guys.
where can i find this option? thanks

This sounds like something I had problems with a while back.

I fixed it by resetting the midi ports. Check the thread here: https://www.steinberg.net/forums/viewtopic.php?f=226&t=72585

Gday andy4efc.

try the time stamp thing first as it is very quick and worked for me.

you will find it under device setup, then Midi devices. I think the check box is down the bottom somewhere, just tick the box and hopefully you will be on your way.

thanks guys you really helped me :slight_smile: