MIDI Recording Inputs Always ON?

Hey guys,

I need to set the recording options in Cubase so that unarming the MIDI track also turns OFF the MIDI Input of the track. As it is now any channel that has monitoring enabled also allows the MIDI Input through the channel from the controller.

An example: I have two MIDI tracks and one Instrument track. The Instrument track has an empty instance of Kontakt loaded, and a VST3 plugin for MIDI processing inserted as an audio insert. The output of the two MIDI tracks are sent to the VST3 MIDI Plugin Inserts on the Instrument track. When recording I need to monitor MIDI Tracks 1 & 2, but only the armed track should be allowed to pass on MIDI from the MIDI controller to the VST3 MIDI Plugin. Now the Plugin receives controller MIDI both from the armed track and the unarmed track. How to stop the controller MIDI from the unarmed track?

There are also two additional Instrument tracks where the VST3 MIDI plugin outputs should be routed.

I have done this setup in Reaper, but cannot figure out how to do it in Cubase.

Thanks in advance for any suggestions.

MIDI Track In/Out

Plugin Track In/Out

P.S. The Plugin should have the MIDI input set to “Not connected”, and this works fine because the MIDI signal is still routed to the Plugin. Se pic below.

Plugin Track In/Out 2

Hans Adamson
Art Vista Productions
www.artvista.net

Hi,

Sorry, why do you enable Monitor on the MIDI Track 2 too, please?

The plugin processes multiple MIDI channels in real-time. While recording to one of the MIDI tracks, I need to hear what is already recorded on the other track. Also, the effect of the plugin will be calculated from the combination of what is currently being recorded from the controller to the armed MIDI track 1, and what is already recorded on MIDI track 2.

If the MIDI inputs are open also when the track is not armed, there will be two streams of the same MIDI (both incoming from the controller) to the processor and it cannot process properly.

In Reaper, when a MIDI Track is unarmed, the input from the controller is muted on that track, while the MIDI track itself can be monitored.

So I want the input from the controller to be automatically muted on a MIDI track when it is unarmed. Is this possible in Cubase?

Hi,

If you, by “monitor the track”, mean to hear what has been recorded already, just disable the Monitor button.

In Cubase the Monitor On means, the recorded data/signal are ignored and you listen the data/signal on the input.

Thanks Martin,
I was trying to replicate a setup from Reaper, but the functionality is different in Cubase. In Reaper the Input Monitoring is turned off when the track is unarmed, and this threw me off, when Cubase didn’t work the same way. Is there any way to link the arming of a track to the input monitoring on/off in Cubase?

If you are talking about midi tracks only then don’t use the monitor at all. Midi signal will get to that track when it’s record armed.

Thanks misohoza, yes I just noticed that. The setup in Cubase has to be done the opposite way compared to Reaper.

CUBASE:
MIDI tracks: Input monitor OFF
Instruments Tracks Input Monitor ON

REAPER:
MIDI tracks: Input monitor ON
Instruments Tracks Input Monitor OFF

I have another problem with my VST3 MIDI plugin setup:

  1. MIDI Track 1 receives MIDI from controller on all MIDI channels.
  2. MIDI Track 1 sends MIDI on channel 1 to VST3 Plugin on Track 3 audio insert.
  3. Instrument Track 1 receives MIDI on channel 1 from VST3 Plugin on Track 3 audio insert.

Problem: Instrument Track 2 is also receiving this MIDI, even though it is set to channel 2.

How can I make sure only Instrument Track 1 is receiving the MIDI?

Thanks,
/Hans

Try it without the monitor. Midi sends will work even if the receiving track is not monitored or record armed. If you want to send midi on the same channel as received set the channel to “Any” for your midi track.

Thanks Misohoza, will try when Grammys are over! :slight_smile:

Thanks again for your reply, Misohoza. Changing the Instrument Channels to “Any” channel fixed the problem. Now MIDI Track 1 will only be routed to Instrument 1. :slight_smile:

I hope you can help me with one more issue:

I want to load a VST3 plugin on an instrument track. To be able to do that I must:

  1. First load an instance of, for example, Kontakt to the track. Only then will the “Audio Inserts” be visible in the “Inspector”.

  2. Load the VST3 plugin to one of the “Audio inserts” in the track Inspector.

  3. Remove Kontakt, and the plugin remains on the instrument track’s “Audio Insert”.

Is there a way to load a VST3 plugin to an instrument track without first having to load an instrument (Kontakt) to the track? I want to skip step 1 and 3.

Thanks in advance for any advice.

/Hans

Any reason why you’re using an instrument track, when you’re not using an instrument? Why not just use an Audio Track?

Or if you’re trying to use the VST3 plugin as a send effect, make an FX channel?

Hello Nico, there are more info about this setup in the first post of this thread. It is a VST3 MIDI plugin. If there is a way to load it on an FX channel, maybe that’s the simplest way to do it without loading an instance of Kontakt? I don’t see a way to route the MIDI back to the instrument tracks when it is on an Audio or FX track?

So, is there a way to load a VST3 plugin to an instrument track without first having to load an instrument (Kontakt) to the track?

I’ve just tested the following setup using just a regular Audio Track to insert the plugin:

  • Create new Audio Track called VST3 MIDI Plugin
    – and insert VST3 Midi plugin (I used ScalerAudio 2) as Insert into that track

  • Create 2 Midi tracks, both sending output to VST3 MIDI Plugin > Insert1 Scaler …
    – MIDI to Plugin 01
    – MIDI to Plugin 02

  • Create 2 more Midi tracks, both receiving input from VST3 MIDI Plugin > Insert1 Scaler …
    – MIDI from Plugin 01
    – MIDI from Plugin 02

Seems to work just fine, merrily routing midi to and from the plugin inserted into an Audio Track:

1 Like

Thanks Nico,
How did you insert the VST3 plugin without first inserting an instrument like for example Kontakt? I cannot see any Audio Inserts in the Inspector, unless I have first loaded Kontakt.
Edit: OK I see you didn’t use the Audio Insert. Let me check here first.

I am trying to set this up, but haven’t got it right yet. Shouldn’t the two last tracks be instrument tracks? I need to load Kontakt there.

Edit:
OK I got it working correctly with the Instrument tracks loaded with Kontakt.
Thanks a lot for the help! I didn’t know the audio track could also work for this purpose. :slight_smile:

I made a small change: I set the Instrument tracks MIDI input to “Any”. Without this setting, both instrument tracks would receive any MIDI input.

1 Like

Glad you got it going. There are many routing options - I didn’t try to emulate your exact scenario, just wanted to show that you didn’t need a fake instrument track, to host a midi generating VST3 plugin. :grinning:

To the best of my recollection, the one time that midi tracks are more capable than Instrument tracks is when wanting to route one midi track to many midi destinations.

Thanks again Nico! :slight_smile:

You wouldn’t by any chance also be knowledgeable about Samplitude?

Is it possible to assign MIDI CC to VST3 parameters in Cubase? If so, how do you do it?