Midi recording weird enharmonic spelling

Hi, all!

I’ve tried to find an answer to this, but can’t seem to find what I’m looking for, although I’m sure it’s out there somewhere.

Anyway, I’m trying to record some piano, and I’m recording into two staves at the same time. I’ve changed the splitpoint value to 53. Otherwise, nothing is changed as far as I know.

The music is in A major, but when I tried recording a simple A major and B minor chord, it was written with loads of double flats. Please check out the attached image.
Thanks in advance for any help.

All the best from Jim-Roger Knutsen

That’s certainly not the kind of result I would expect you to get. Does this persist in a newly-created score?

Daniel, Jim hadn’t updated to 2.2.10 - there was previously a bug whereby the key signature at the start of the Flow was considered, rather than the prevailing one.

Aha, good stuff. Thanks, Leo.

Yes, Leo and Anders asked me to check if I’d updated, which I hadn’t, and when I did (and rebooted the computer) all was well!
Thank you all!