Midi Remote API not able to load JavaScript files?

I am a new customer to Steinberg - the sale on Nuendo for October 2022 ended yesterday - and I have had issues with the MIDI Remote - with just using the mapping tool it keeps showing up disconnected when used on a Kontakt7 track. No Midi controllers for Mod Wheel - sometimes they do work but mostly not. (Nuendo is just “Cubase on Sterioids” from what I have read - it should work here too is my assumption).

I found the references to the Midi Remote API and found the Git Repository - where a good number of the scripts in there seem to be from May - so maybe it worked - I bought the product and the revision was from August, and just applied the update for October and still not working well for me.
I figured I would try my hand at scripting but I seem to be hitting a roadblock here too.
Here is what I have tried:
Open the “Lower Zone” and click on the “Midi Remote” Tab
Then in the upper Left corner of that click the “four boxes”
“Go To Midi Controllers overview”.
In the title bar of that lower window - Right-Click and check off Scripting Tools.
Scripting Tool Icons section appears on the Menu bar of that lower window.
The 2nd icon in the Scripting tools “open MIDI Remote Scripting Console” - in that window - three columns of names - nothing is selectable.
Hit “Reload Scripts” - no change of the columns being selectable.
“Open Script Folder” - directory with “Midi Remote\Driver Scripts” - and we can look at the scripts and there are JS files in Public, and there are JSON files in the Local in a saved script from the Nuendo tooling work.

If you click on the gear next to “Last Midi controller” it opens “Midi Remote Manager” Window - then click on the button “Import Scripts” it has a filter of the file extension - looking for *.midiremote files did not find anything with that file extension - if you search with that extension you do not see anything - but you do see some *.js
but if you change the filter to be Any File and try to import a *.JS file you get “Script Archive could not be imported” in a message box.

I got VSCode open to the right directory - read that it should be saved in Local - I tried copying a Public sample to the Local with a name - stop and restarted Nuendo - but nothing - cannot seem to get this to start for me - I am sure I am missing something - otherwise there would not be a repository on Github - or the feature got disabled before I purchased it??

Any pointers would be helpful.

Edit: I had hoped that I could record the VST Plugins from a Midi Track - and based on some of my research - It seems to only work if you use single instrument on a Kontakt VST Track - and then I seem to be able to record the automation of the Dynamics and Expression.

Maybe you have misunderstood what MIDI remote is doing?
What is your hardware controller? Is it connected to the system?

I have an older M-Audio Axiom-49.
I have been able to use the Midi-Remote tool that can let me draw controls that are mapped to my keyboard layout.
However that file is saved as a JSON script - and not using the API.
I have found that in Using Kontakt 7 as a VST - and loading multiple instruments - one per track - the CC controller numbers are not making it to the instrument - and if I go to map - it can often tell me it is disconnected.
I switched to Nuendo(Cubase) for a stronger Video processing.
I am used to a DAW that easily learns Midi Mapping by a right click and Midi Learn - and even that is not working right.
So - I am thinking that the only way to get a good Midi Remote setup is to program my own to allow me to have a consistent setup that works.
It feels like the Midi detection from my Keyboard is just inconsistent right now.

I decided to look at my devices in the Windows Device Manager - and found my Axiom-49 and looked at the driver definition. It said Generic Midi Driver.
I had built this computer on Windows 10 image in December of 2020, and once my sound card was available - in June of 2021 - I started up my old daw and had no issues with working with the Generic Midi Driver.
So - I did a search for the Legacy M-Audio Axiom 2nd Gen Drivers - and found one! dated from 2010 - which sounds about right. I installed it. I setup a Kontakt Instance, Tested the VST track, and added two MIDI Tracks and assigned instruments in the Kontakt Instance - used the Midi Learn - and they worked correctly. The Driver software has to be there for Nuendo (Cubase) - This makes sense to me - it demanded to have the right software hooks to the keyboard controller(so it gets the right interrupt handlers) to handle the data correctly. I still have a lot to learn - only have had this for a month - but we should be making better progress now. Had not remembered that we skipped the USB Controller Driver.

1 Like