MIDI remote buttons only work once

1st-gen M-Audio Axiom 25

Transport and Quick Controls are not responding after the first press/button/knob movement. Cycle button works, but instead of toggling the state with a single press, a toggle requires two presses.

What might be going on?

Creating the buttons is simple and the MRM and mapping assistant recognize button presses correctly. However, the DAW itself does not.

1 Like

Have you tried to make your hardware not be in toggle mode?

Different hardware seems to have different words for the non-toggle mode. I’ve seen “gate” and “momentary”, but there may be other words, too.



I actually turned toggle off for all buttons in MRM to get by. I guess it makes sense, since Axiom sends 0 or 127 with alternating button presses. Also, matching on and off values doesn’t make the Toggle option in MRM work. Based on your suggestion, I need to take a closer look at my options on Axiom.

Axiom Rewind/Forward buttons were sendig something else than 0 as the “off” value and after making the off value 0, they behave as expected. However, changing on/off values on the controller didn’t allow Play/Pause toggle behavior for transport Start. For the time being, I need to press Stop to pause playback.

there’s an undocumented hack / trick, that gets you close to what you want:

in the MIDI Remote

  • connect the PLAY button the Transport > Start
  • do NOT connect the STOP button to Transport > Stop
  • but do connect the STOP button to Key Commands > Transport > Stop


Yes, because the MIDI Remote interprets every CC value > 0 as on ON message for MIDI Remote Toggles - and that’s why you originally experienced what you did.

1 Like

Awesome, thanks Nico5 - with the “undocumented hack” I’m now able to Play and Stop with one button.

I also realized that for “Pause” I needed to change Stop behavior in preferences to not take the play head back to start with the first press.

1 Like

I was able to get the same behavior by

  • Only connecting Transport>Start
  • Making sure the hardware was in momentary or trigger mode
  • Setting the button to Toggle in Cubase.

But did you connect a STOP button at all? – If not, your method is totally fine.

nope. When you set it to toggle it stops when you press it again, as long as you don’t set the hardware to toggle.

Yes, in my setup I’m using gate (not toggle) on the hardware) and use toggle in the MIDI Remote.

The issue I offered the work-around for arises only, if you map another button in the MIDI Remote to the Transport > Stop function, because then the Transport > Start stops toggling.

1 Like

That is very useful information.

1 Like

Hi all, this is intended behaviour. The default way for remote controlling transport is using separate Start and Stop Buttons. Having a toggling Start-button is only a fallback feature for those devices having only one button (like the Play button on an apc 40 or the LaunchKey Mini)