MIDI Remote Function Not Working for Arturia Keylab mkII 61

Hi,
Like many others, I’m having trouble mapping my MIDI controller keyboard. I have an Arturia Keylab mkII 61. My system is Windows 11 Pro, Cubase 12 Pro and a Focusrite 18i8 Scarlett 2nd gen audio interface.
When using the new MIDI Remote setup, turning each of the encoders creates a new icon for that particular knob. But when I click on the fader tab on the far left to start mapping the faders, only the first fader creates a new icon. Moving fader 2 does not create a new icon (control) and the first fader that was created now no longer appears to function.

Things get stranger at that point. At the top of the mapping editor it says to click on an empty space to create a new control, or something like that. It does create a new fader wherever I click within the editor, but moving the second fader does not control it and now the first fader no longer moves the first fader in the editor but instead tries to move (albeit very erratically) the second fader representation in the editor. After that, I can no longer add additional faders and I give up. Also, the Transport and onboard Edit buttons on the controller (Undo etc) do not work. But as usual, the keys and pads all work fine.

I do notice that the MIDI signal indicator at the bottom of the Cubase screen does in fact show that it IS receiving MIDI messages with every press of the buttons, faders and knobs of the device. So it’s not that it’s not getting signals.

I’ve noticed in the forum, that many people are having difficulty mapping their respective controllers with the new MIDI Remote section of the Editor. Has anyone out there gotten their Arturia Keylab mkII to fully work?

Any help is greatly appreciated!
Thanks!
Shawna

Hi,

I don’t have that device, but it seems that you need to enter DAW mode on the keyboard, then select one the different presets (you should select either Cubase or MCU mode).

Hope it helps,

Thomas

Thank you. I did try that, but it still acts weird. I cannot get more than 1 or 2 faders to register in the MIDI Remote thing and even when I do, they act strangely. I will keep looking for solutions.

Thanks again!
Shawna

And why not start from the base of the
Keylab MK2 Essential and add or modify as needed
I too have a Keylab MK2 88 but I don’t use the new midi remote
my keyboard is always configured with the mackie control
I think remote midi is a very good future development but needs to be refined
I also have a touch screen and impossible to access all the functions that I have set up
It must be said that Cubase 12 has also evolved a lot in terms of PLEs and macros

1 Like

Thank you, Freudon!
That is a great idea! It crossed my mind to try that, but it seemed like wishful thinking. I wasn’t sure it would work. It’s certainly worth a try!
I will try that today!

Thanks again!
Shawna

Hello, Freudon!
Hey, do you have any suggestions for learning Arturia’s MIDI control center? I have the hardest time understanding it.

I also don’t understand how to use the MkII as a standalone instrument, as is shown in the advertisements. (Using the keyboard display to navigate patches etc.)

Is it possible that the MkII is not properly recognized by Cubase? Have I not set it up within Cubase? It’s so frustrating. It’s a really nice MIDI controller!

Thanks again!
Anyone else, please feel free to chime in on this!
Shawna

Firstly
4.2. Choose a DAW preset
Hold the DAW mode button for one second to enter the page
for selecting DAW presets. Then turn the central potentiometer and scroll
the list to find the name of your DAW. Click the middle potentiometer to choose
this preset, and then the KeyLab mkII features will be reconfigured to
correspond to the most important functions of your DAW.
4.2.1. List of DAW presets
1 Standard MCU
2 Standard HUI
3 Ableton Live
4 Logic Pro X
5 Pro Tools
6 Cubase
7 Studio One
8 Reaper

Then in cubase
Choose Mackie Control Device(for you one and not two)


I uncheck the midi in input of the keylab

and I rule the tracks on all midi inputs

and everything works for me I don’t use the new midi remote
I don’t need it my keylab MKII 88 keyboard
works just fine like that
and for all other functions I use a touch screen

1 Like

I have exactly the same problem!
I tried already the suggestions by Freudon (which are also on some youtube videos).
This did not solve the problem - can’t map it. Even in the HUI mode the basic transport don’t work properly (e.g. the Metronome can’t be switch on/off., the Read/Write are not responding correctly, etc). I decided to send my mkII 61. It just blows my mind that such an expensive piece of gear advertised as compatible with Cubase can’t even work when you select the ''Cubase DAW mode" or even the HUI !
Note that I do not have this problem with my Komplete Kontrol M32. I managed to map it fine and can use all the quick control for both the DAW functions and the VST functions. But I can’t understand Cubase releasing a Midi Mapping function that looks so great on paper but does not work consistantly in practice.
Now I’m just wondering which 61 Midi keyboard would work best with Cubase (including Midi intergration). Novation?

Hello there. I have successfully mapped my Keylab MK2 to Cubase Pro 12. There are a few things you need to understand about the MK2 and that is the modes. In order to correctly map the mk2 to cubase the mode should be set to user. You should also make sure that the knobs and faders are not currently mapped to existing Arturia CC assignments. This is really important. Cubase and Mk2 get weird when there are preexisting assignments. I can get into all of this further if anyone needs me to.I could probably even share my map file and my MK2 settings file. reach out privatly if you’d like that.

1 Like

@vhsorbeta - please DO share your script. I’m ready to send it back. It’s a lovely machine, but it shouldn’t be this much work to use all the features. Arturia’s documentation is pathetic. Kudos to you and others who have managed to get the pieces to play nice.

I’m happy to share with you. sadly i’m out on holiday until feb1. if you can wait that long i can send it to you

1 Like

Enjoy your holiday! The return window for the product should last beyond Feb 1, so all good. Thanks so much!

Have people seen this link below? I tried the new remote, wasted my time - days. I went with Mackie as advised by Arturia. Here are the settings :

This actually helped. Some buttons are now working some are not but at least its some progress.

I followed the steps for configuring key lab mk II with cubase.

Im still having issues with the commands and buttons which are shown in the Studio set up/Mackie Control/User Commands. Somewhere I have missed something but on the right track.