MIDI Remote - M-Audio Keystation Pro 88

Hi all.

I’m currently trying to make a script for the above controller. I’ve managed to map the knobs, faders and buttons, but I just cannot get the transport buttons to be picked up by learn.

I reassigned them on my the device itself, at which point ‘learn’ saw the buttons, but immediately erased them as the ‘red box’ moved to the next space on the learn screen.

Does anyone have any ideas?

I’m away from my studio for a day now, so I’ll try again with a fresh head later.

1 Like

When you create a new button or dial it always creates an extra one so you have to delete that one. The button you just created is generally the previous button if that makes sense.

Also I would not select my dials or buttons on the learn screen to assign functions. Instead, when you open the mapping assistant a new window appears, in that there is a much smaller controller pic in it. I select the buttons I want to assigning functions to in that new smaller controller pic actually in the mapping assistance box,

Hope that makes sense, it can be a bit fiddly.

1 Like

Hi all.
After a good read through the manual (it referred to Appendix H which doesn’t exist), I found that if I did a factory reset of the controller, then choose factory preset 07 (Cubase SX/Nuendo - yes, it’s that old), the transport buttons are reflected in MIDI Remote set up.

Thank you for all your help and suggestions.

Thank you. Yes, I was following this method, but as I found out, without the controller being in the correct mode for Cubase the transport buttons are ‘invisible’ to Cubase.

Aha so it’s a controller specific thing. Interesting, something else for ppl to look out for.

Yes, it would seem so. I’m all communicating now, so will try to make my Remote Script / Map tomorrow.

1 Like

Thank you all for guide
i fix mine transport controls , but i need to tap them twice to work
Crazy_Pops can you share your Script