MIDI Remote Mapping not installing

Cubase 12 Pro 12.0.52 Build 393
Win 10 Pro 21H2 Build 19044.2604
Stream Deck 15 key and Stream Deck Plus attached.
ASIO4ALL audio driver.
Alesis iO2 attached
Behringer UB802 mixer via Behringer UCA200
Impulse49 kbd which plays VST instruments no problem, so that part of the MIDI connections/ports is fine.
Steinberg dongle attached.

When I hover my mouse over the Mapping Assistant icon at the top right of the screen the tooltip ends with a <!>. Also, the Remote mapping is not showing as a tab in the lower zone. From theStudio menu, clicking MIDI Remote Manager opens the dialogue, but on clicking Add Surface+ the dialogue closes and nothing else happens.

I’ve uninstalled Cubase completely, plus deleted the folders in the Roaming section etc etc. Reinstalled but still no joy.

Any ideas? I suspect it’s something do do with Windows, but what? (Cubase works fine on my MacBook in all respects) Thanks.


This seems normal
No idea what that <!> is for though …

Maybe that’s just this setting:

Right click just under the lower zone … or that click that cog wheel

P.S. : I am a retired Belgian Air Force pilot. Cheers!

Thanks, but no, the option to add the MIDI Remote in the lower tab is not there. The <!> mark probably means it’s faulty (I think).


I’m thinking it may have something to do with the USB ports, or something, or the weather…

Is there something to see here:

And I understood you live in England …

I just discovered that this is sort of a placeholder for “Key commands”
I assigned a keyboard shortcut and it shows now in the tooltip

1 Like

Thanks Fantom (F4?), you’re being very helpful. I tried setting the key commands, but it didn’t help.

Earlier I disconnected all USB devices, uninstalled and tried a fresh reinstall, still no joy. So, yes, it could be the weather (currently ligh snow). All very anoying as I want to control Cubase from my Novation! Grrr…

Yes I know, but zilch on my Win 10 PC - all OK on my Mac though.

I don’t understand where the failure occurs.

  1. From here,

  2. You click the big plus sign.

  3. You select Novation as the Vendor. Since there’s no factory supplied Impulse script, you might have to go with the “+Add Model” option and create your own.

  4. You assign the input/ouput ports of your Impulse 49.

  5. If it works and it gives you a blank page upon which you can start building your remote, like this:

… then it’s working fine.

If it’s not like that at all, at which step does something else happen?

Unfortunately, the MIDI Remote isn’t there at all - it’s not in the TAB at the bottom. It doesn’t seem to be installed.

Did you try restarting Cubase in safe mode (hold ctrl shift alt right after double clicking, choose “Disable preferences” from the window that pops-up)? I can’t seem to find a specific component in any path for the MIDI remote, so maybe it’s just corrupt preferences? Do you have a “C:\Program Files\Steinberg\Cubase 12\midiremote_factory_scripts” folder for example?

Thanks for your help. Tried the chr shift alt method which did bring up the dialogue to disable prefs, but still no joy. Yes, I do have the folder which is populated with .api, Public, jsconfig.json and a README_v1.html file. All the files are in the folders, a total of 39 files in 29 folders, 6.87 MB

I’ll have to send a ticket into Steinberg to see what they make of it.

Thanks for your help though.

1 Like

It must be something on the Windows side of things, then, just as you said. But it’s not easy to guess what it might be. Good luck!

1 Like