Midi Remote - Novation Launchpad - Unusable

I have a Novation launchpad that I have been using as a Generic Remote for the last two or three years. It is great to use for transport, jumping around markers and running macros.

So importing my script into Cubase 12, it says it is legacy and will be discontinued.

Fair enough. So last night I created a Midi-Remote thing for it. Simple enough to set up and much quicker than Generic Remote way of setting things up.

However, once I tried to use it. The Transport buttons I mapped, took around 15 seconds to actually do anything and locked up Cubase whilst it did whatever it was doing.

Then Cubase crashed, but continued, so I exited.

So I gave up for the night.

Tonight, I deleted the midi-remote and started again from scratch.
Same thing. Things like Add Midi, Add Mono track, Add Instrument track are instant. Start / stop take 15 seconds and after a few button presses it crashed to desktop.

I’ve sent the logs to Steinberg, but is anyone else seen this issue and what can I do to fix it, other than deactivate it and go back to the Generic Remote way of doing things?

Edit: Here is the export file if anyone wants to try it and possibly crash Cubase themselves.
Novation_Launchpad.midiremote (8.0 KB)

Here is the crash dump. I’ll transfer it to my programming PC and take a look…
Cubase 12.0.40.317 64bit 2022.9.7 20.43.00.890.dmp (747.0 KB)
p

Post the crash logs here too, might be useful,

see OP

Frustrating. I was using Novation Launchkey mini mk2 today for the for the first time on Cubase 12. It worked fine but I couldn’t get the nice new graphics - ‘midi remote’ I think it is called, so I emailed Novation.

Have you tried emailing Novation?

I haven’t contacted Novation.

Last week, we got a Novation Launchpad mini to work with midi remote. It just seems to not work with the bigger version.

I thought the Launchkey (maybe no mk2) was in the list already!

Yes mk2 isnt on the list. Novation reply emailed me the steps to get it working. Through Devices - add Mackie HUI - this adds to remote devices - then port set up etc

However, I have just spent 40 minutes trying to set up the scripts, rather than doing what I enjoy. I would like the script to be made by someone to run it as most would assume is needed (then personally adjust) because I am able import scripts. Someone in the world must have done this already but it really should be a job for Novation.
image

I bought a 2nd hand launchpad mini, to use, since that is what my mate successfully uses and he gave me his script.

I can’t get that to work either. Either crashes Cubase to desktop, locks it up for 15 seconds per button press or locks it up completely.

Gone back to the way that works.

Dowloaded the new Cubase update.

A little easier to set up the launchpad. Same issue. Locks up Cubase for many seconds on each button press. So unusable.

Back to the old working method.