MIDI Remote Script Broken

Cubase won’t recognise my Komplete Kontrol MIDI controller anymore since I reinstalled the drivers for the KK. The Controller is now visible as “2 - Komplete Kontrol - 1”, but the MIDI remote script is looking for “Komplete Kontrol - 1” and this doesn’t seem to be changeable in the MIDI remote manager. Is there anyway to change this?

Hi @Charb, you could adapt the according script using the (unfortunately) changed port names. Or you could just activate the script manually by clicking the (big fat) plus button in the MIDI Remote lower zone tab.

How would I adapt the script? I cannot change it from the MIDI remote manager
1

Is your other suggestion map out the MIDI remote again?

Thanks

I unfortunately don’t understand what you’re asking.

First thing I’d try is rebooting the system. Maybe the port names will revert back to what you have now. It looks like the OS is remembering the old drivers, and stacked a new name for these new ones?

If rebooting doesn’t take you back to the old naming convention for the ports…

I think you’d need to unload the current running script first (remove controller surface), then load it again. It should ‘ask’ and allow you point the remote map to the newly named inputs and outputs at that point.

Hi Jochen. If I remember correctly @Charb didn’t create a script but rather used the assistant.
@Charb as Jochen suggested, here’s a screenshot that may help:

Another way is to disable your remote surface by clicking on the down-arrow on its title and then selecting “Disable Controller Script”:
εικόνα
This will get you to the MIDI Remote Manager window, and now you can select the surface and click on “Enable Controller Script”.
If everything went OK, at the MIDI Remote Tab at the Lower Zone you will no longer see the disabled surface but the big plus icon Jochen told you about. Click it, select your surface from the list and reassign the new ports.

1 Like

Thanks for that. I can delete everything then start by adding a new surface, when I ‘import script’ though it just reverts back to the way it was.

Hi again M.C I did get it working more or less the way you described yesterday, but I’ve come to use it today and it’s reverted to the old ways. It’s started working again just now for some reason, but I’m pretty sure it’ll break again when it feels like it…

It’s reverted back to the old drivers once again :confused: is there no permanent solution? Creating a new surface from scratch isn’t ‘quick and easy’ depending on your set up. I’ve had to recreate tens and tens of these things because they just stop working. I don’t even create music with Cubase anymore, I’m a full time beta tester, and to be honest I’m rubbish at it.

Can you navigate to your documents folder and then to Steinberg\Cubase\MIDI Remote\User Settings and upload a screenshot of this folder’s files?

Thanks again for your efforts m.c. I had to delete the one created this morning because it’s name contained expletives trying to get it to work :slight_smile:

OK. From what I see you have multiple names for the same controller there. Do you need all these different scripts or you need just one?
If you need just one,

  • Close Cubase
  • Delete all these files which start with Native Instruments
  • Manually delete all the subfolders inside the yourDocuments\Steinberg\Cubase\MIDI Remote\Driver Scripts\Local\Native Instrumements for the scripts you don’t plan to use, for example the subfolders 12, AS, Komplete Kontrol S49 MKII and so on, until you’re left with the script you want. Finally upload here the json file of the script, so we can have a look.

2
This is the file I’ve been using to back up the MIDI Remote too. I’m not sure what the difference is between this .‘midiremote’ file and the 'json. files…

Thanks m.c. I won’t be able to try this now until later in the day. I don’t need all those scripts no, each one was a new attempt to get something working because the last attempt wouldn’t. I’ll get back to you later. Thanks again

I’ve tried to follow what you asked, I seem to be left with 3 files though, I don’t know if I need “blockeddriver.json”, there’s that and a script in user settings, and there is a script in the local folder too. I’ve uploaded all of them with a picture of their locations. Thanks


CORRECTION: after trying to upload these files the forum says these .json files can’t be uploaded, but I can upload .midiremote files. I am completely lost as to what is going on. I have a degree in computer science and I have no idea how to operate what is supposed to be a ‘professional software’ that’s ‘plug and play’ and “boom!” like Dom Sigalis says. I can’t get the most basic functions out of Cubase without it breaking, every single project there is a new problem!!! I might as well buy a cassette 4 track.

This one contains any midi remotes that you have disabled. If you don’t have any, just remove this one as well, no problem.

Remove also the other one starting with Native Instruments, always inside the user settings. We need a “clean” installation.

KEEP the one inside the Local folder, since this is the one you need to have.

After this, you can open Cubase again and see how it goes.

Ok, I’ve done that. I’m just at square one again…


This is exactly what we want.
Now, click on the big down-arrow (the one we see at the first screenshot) and select “Disable”. After that, go to the MIDI Remote Manager (the one we see at the second screenshot) find this script and click “Enable”. If it’s done correctly, you should now see an empty window with just the “big” plus sign to add a midi remote at the lower window. Press it, select the script and assign the ports you want.

I’ve done that, and it seems to have worked, I didn’t even have to change the ports it has done it automatically. All the mapping are missing though, but the knobs and buttons remain empty.

I’ve got it working 3 or 4 time over a week or so using probably this method (clicking and trying everything), then I’ll probably try it again tomorrow and I’m back at square one. It seems I have to map a new MIDI remote over and over and over, so much that that’s all I’m doing instead of making music.

I’m seriously thinking of switching DAWs. I got Ableton Lite with Komplete Kontrol. I just need something where I can sit down and actually make music.

Completely broken again. I was so fed up with it not working so I started a new control surface (for the 200th time), it worked fine for 2 days, now it’s going back to the old ports of “Komplete Kontrol - 1”. This port doesn’t even exist in the “MIDI port setup” of Cubase, or anywhere else on the computer such as the audio interface settings of Komplete Kontrol. I’m so fed up of Cubase, I bought it to make music, not be a Steinberg beta tester. If this ever gets fixed I’ll be confronted with another problem to solve.