MIDI Remote sending delayed (and incorrect) messages to my controllers


edit: This is in both Cubase Pro 12.0.30 as well as Cubase Elements 12.0.30

I’m working on setting up my midi controllers in Cubase right now, and wanted to make use of the built in GUI for making them, as opposed to scripting right now, as I’m just wanting to do some proof of concept while configuring things.

I have a consistent issue with controllers sending back incorrect (and oddly delayed) midi to my controllers.

Have a look at this data… in particular the last 3 rows here, as this behaviour is very consistent through multiple controllers I use:

For this example, I use my Faderfox MX12 fader controller which sends to Cubase controller channel volume.
In the last 3 rows you can see that my MX12 sends out midi cc value 14, and 40ms after, Cubase sends back midi cc value 13, and then another 500ms later another message comes through with 13 again.
This causes the value to bounce back to 13 on my controller…and unless I make a wider movement, i.e. sweep through more values, I’ll be stuck at 13, as this keeps happening all the time.
I noticed not all values behave like this, and it’s more often occurring on going UP in value. Going down it’s less frequent.

This looks like a rounding problem to me.

I have this issue consistently with several controllers using them either together, or only one connected at a time.

For info: I get this on my Faderfox MX12, Faderfox PC4 as well as my Adafruit Macropad that I set up for Cubase, so it doesn’t seem related to my controller.

This is how my controllers are set up for this:


Is this a known issue? It’s very easy to reproduce, as it happens all the time.
It makes it really hard to do fine movements to set values.

Is there a workaround? Can I solve this by just making my own scripts instead? This seems like something that should be working the way I set it up though.
If scripting is the only way around it for now I’ll do that though.

Here’s another example with my other controller that’s controlling gain on my EQ with midi using an encoder. I’m turning encoder one click, sending value 64, and cubase returns 63 to me 40ms later, and then another message of 63 about 500ms later:

Just do update this, I did try just disabling Transmit to Hardware just to see if that somehow was causing double messages to be returned to me, but that just does what it says really. But I do need to get midi sent back to my controller.

Also I had another go at clicking through values, and certain values seem to be quite consistent in being incorrect, such as my above example of 64 ticking back to 63 when I was controlling my volume faders.

Help :slight_smile:


Do you use the output MIDI Port in other (old) Remote Device by any chance, please?

No, but I may have some other legacy controllers setup from older versions.
But neither of these controllers are ones I had before Cubase 12, so none of these have an old setup.

I am pretty sure I tried this before, but I can try later today after work to see if there is anything whatsoever speaking MIDI in midi monitor.
I can do my best to just strip down everything as well. But I did try this with nothing but a single MIDI Controller and I still get this.

The actual value 64 sent returning 63 from cubase does seem like a rounding (or not rounding, but a direct cast from a float to int though to be fair, but hard to say without knowing how it actually works under the hood).

Otherwise this should be very easy to test.

Steps would be:
Create a midi controller with a knob or fader according to screenshot above. Set it to control channel volume of a given track. Monitor the MIDI out and in and tick up the value 1 at a time and see what Cubase returns.


Are you using the JavaScript or the Mapping Assistant, please?

This is strictly using the GUI with Mapping Assistant.

I wrote it earlier in the post (in a bit convoluted ways) and asked if I need to go javascript to solve it. (Not a slag on not reading my message btw, just stating it. I know I wrote a ton of text :smiley: )


Sorry, I didn’t read your text fully and patiently.

In this case, I have seen similar report here on the forum already. Unfortunately I cannot reproduce it here on my side (so far). Would you be willing to share the *.midiremote file with me (via private message)? I would try to reproduce it with your file. Thank you.

Absolutely. Wont be until later today though as I’m at work currently.
I can simplify it as much as possible first to get a basic (foolproof?) example that produces it.

Thank you!

1 Like

Dropped you a DM now with the .midiremote file @Martin.Jirsak

Also posting additional information from the DM here, for anyone else to also chime in if they want:

I made a single audio track in Cubase Elements 12.0.30 (as mentioned I also have Cubase Pro and same thing happens, but i went Elements for this now because it’s simpler to get a quick example going.
I hovered the volume of the track volume fader, and MIDI keeps bouncing just like in attached screenshots. Certain values always round down…0 to 1 for instance, always returns 0 for me.

Also potentially noteworthy, I run Mac OS 12.4

Check this sequence from MIDI Monitor:

If I just do single clicks on the encoder it ticks up to 1, and goes back to 0 from Cubase.
Quicker sweeps gets through it, but it’s a bit of a mess.

Adding on more info with midi port setup and midi devices:

mackie/track quick controls/vst quick controls are all set to no input no output. So nothing else MIDI is going on.

Any further ideas regarding this? I hope you received my midiremote file.

As weekend is coming up I’ll have more time to simplify and maybe try other things if needed.


I don’t understand your MIDI Ports. Why do you have the IAC Driver HackieMackie In and Out in the Inputs and Outputs? Same for the IAC Driver Streamdeck and Return.

They are ports I set up on my Mac for other applications.
Hackiemackie is something I used to interface with my mackie controller I used before.
None of them are doing anything in Cubase. Likewise with the Streamdeck.
There’s no MIDI going to or from them. Same with the arturia keystep and network ipad thing.

Anything new that I could try? Or did you manage to reproduce my problem?

I tried setting up the same thing in Logic and Bitwig, and only Cubase is giving me this problem.

I don’t mean to whine about this, but I’d really like some pointers on how to move on with this.

Anyone else experience a similar issue? I’m not really wanting to have to make my own script unless I have to, as the GUI for custom midi remotes is quite nice.

I might have some more time to trouble shoot this a bit this weekend, but I’d really like to know if there’s anything else I should supply for this, or if this should be considered a bug or not.

Right now I’m still not having much success with this, so maybe I need to write my own script to make it work?

I know you’re on vacation, but I had some more tests.

I upgraded to a Mac Studio today, and with a clean Cubase install and only my single MIDI Controller connected I still get the exact same problem, so I’d say with certainty that it’s not my computer at least.

This topic just feels dead now as it seems I am the only one talking about this.
So I guess for now I have to write a script in javascript?

I really really would like some kind of investigation for this though as I do have it happening on 2 computers, with one being a clean install with nothing else on it.