Midi setting in layer 2 doesn’t save with program

Hi, I’m playing Keyscape in one layer playing it from my Studiologic SL88 and I’m also using the Korg NanoControl to control some parameters from Keyscape. So I set up layer 2 so I can use NanoControl and get everything to work and then save the project. The problem is when I open up the project the MIDI setting is gone in that second layer and NanoControl is not showing and then I have to change the MIDI setting to get it to recognize it again. Thanks!

How exactly do you do that? You use the Shared Instrument, or Learn, or how else?

Check Devices/Connections, is it present there? Maybe you changed something in the hub - although that shouldn’t make any difference, ports are also changed with the project.
We’d like to help but need more details. Best to have a step by step repro such as

  • new project
  • create 2nd Layer, assign to “MIDI IN 2”
    …etc.

As I mentioned previously I use both Studiologic SL88 and Korg NanoControl via USB with VST live. I used Shared for layer 2 so that I can use NanoControl to be able to tweak to 2 different parameters on Keyscape as I am using the soft pedal on my Studiologic to switch pages in VST viewer. All of this once it’s set up works fine. The problem is of course when I open the project NanoControl is not working and I have to change the setting which shows to shared to get the NanoControl to be able to function

In the second project that I saved the word Keyscape appears in the instrument window but this time no sound when playing from the Studiologic controller. When I click on the Keyscape plugin window Keyscape appears and I’m able to play Keyscape’s test tone from the Studiologic keyboard but I have to manually load the program and once I do that and change the instrument setting in layer 2 to shared everything works fine. It just would be nice to not have to do all that everytime I open a project

I opened up the second project and then VST Viewer and set it so my soft pedal switches the PDF pages and then saved it. It now opens identical to the first project in which the correct Keyscape program loads and sounds but the instrument setting in layer 2 is set to and I have to switch it back to shared in order for the NanoControl to work

One other thing that might be causing the setting not to save. I do have layer 2 instrument setting set to shared and NanoControl works. I use the MIDI learn in Keyscape so Keyscape and NanoControl can communicate. Maybe that’s causing the setting to not save but just guessing

Still struggling to figure out what exactly doesn’t work. I can control a shared Layer from 2 different inputs no problem and it works after loading. So again it would be great if you could provide a step-by-step repro. Keep it simple (no VstViewer assignment if it reveals the problem without that), thanks.