MIDI setup. Using Casio keyboard, Help me!

Hello! my first post, gratz myself.
anyways…

I’m have a Casio WK-1800 keyboard/synthesizer that I have connected to my M-Audio OZONE, MIDI-IN/MIDI-OUT and MIDI-OUT/MIDI-IN.
The M-Audio OZONE is installed, and connected via usb (both ends of the cable) to my computer.
When I open Create an Instrument track (Halion Sonic) in Cubase, and Halion pops up I can press the keys of the OZONE, and i get a signal, and all the sound i want. I can also controll 8 different parameters using the knobs on the OZONE.

BUT! Nothing happens when i press anything on the Casio keyboard. I have the instructions for my keyboard in pdf format and figured out that i need to set LOCAL (in the wk-1800’s settings on the keyboard itself, not on my computer) to OFF.
This will make the wk-1800 send midi signals without making a sound, only making a sound once the signal comes back from cubase, as i understand it. But I can’t seem to get the signal to travel all the way from the MIDI-OUT port on the wk-1800, into the MIDI-IN port of the OZONE, through the “USB-out” (there is no “in” and “out”, i know, just felt like calling it that) on the OZONE and in to my computer, Into CUBASE 6.

Now I’m wondering what I am doing wrong.

Am I missing something? should the signal go from the midi-out on the ozone through a separate Midi-USB cable and into my computer (there-by connecting my ozone to two different usb-ports on my pc, kind-of :confused: )
In that case I’ll buy a cable and try and figure it out from there.

But is there something else I’m missing? :confused: :confused: :confused:

I appreciate any help I can get, and I also appreciate people ROFLing after reading this “statement of absolute cluelessness”. :wink:

So, I just realised that the M-Audio OZONE does not hav a MIDI-IN…
It has two MIDI-OUT… :astonished:

So I’m going to buy that cable, and not work with audio this late at night.

Well you found it yourself, the Ozone can’t be used for daisychaining other midi devices as it can’t accept midi input.
Get a cheap midi interface to hook up both separately, or you can try doing it the other way around, connecting the midi out from the ozone to your Casio and then the Casio to the PC. I suppose the Casio has no USB though, so you’ll need a midi interface regardless.

Thanks for the reply :slight_smile:

Yeah i just got a midi-usb cable, gonna try it later tonight.
But I came upon another wierd problem that probably has a solution that is so easy that i’m totaly ovelooking it.

as i said i can play the keys on the ozone and it sounds the halion in cubase, everything seems to be doin what it should to, but when i press record the sound keeps coming but nothing is recorded, not in the midi track and not in the instrument track. both are armed for recording.

I may also need some help prgramming the casio as a midi controller (or instrument) in cubase 6 if and when i can get it connected. Anyone have any links to some resources about this, or want to take the time and effort to explain it to me, that would be greatly appreciated. Im just the musician guy who can play alot of instruments but have yet to delve deep into the internals of computer-based recording. :sunglasses:

That recording problem is odd, can’t think of something atm because everything sounds right :confused:

As for using the Casio for remote controlling functions, look up generic remote in the manual. That’s the part of Cubase you use to assign buttons or other controllers to functions in Cubase.

okay, thanks, i’ll take a look in the manual. I think I’ll load the different manual pdf’s onto my kindle and spend the weekend just reading, maybe I’ll learn alot, maybe I wont remeber anything, but it’s worth a shot.

I’ve connected my casio keyboard to a “Roland UM-ONE: 1 X 1 USB MIDI Interface With High Performance FPT Processing” and pretty much gotten stuff to work, haven’t tried recording it yet though, but alot of the keys seem to “hang” when I release them, didn’t have this problem when using the keys of the OZONE, could this be a fault internaly in the casio? it’s 4 or 5 years old and has been sitting in a gig-bag for 1 or 2 years in my room (standard room temperature). Could it be “dust” or similar stuff in the circuits? The keys are pressed and depress as they should, and the don’t seem to hang when using the keyboard as a standalone synth with no connections. it only happens when i run it through the HAlion trial bundeled with cubase6…

I’ll try and figure some of this stuff out myself, but i think it is possible that i may not be the only one who as experienced this, so i’m just kindof “fishing for knowledge”.

http://www.soundonsound.com/sos/dec10/articles/cubase-tech-1210.htm

http://www.soundonsound.com/sos/jul09/articles/cubase_0709.htm

Hi Norimbulus,
I have a WK-1600 by chance!!! (Same keyboard except that yours has a 1.4Mb floppy disk drive!!).
Assuming you have the cables hooked-up correctly, you also need to set up the WK-1800 to be sending MIDI signals.

  1. On the right-hand side of your keyboard you have 5 buttons, the second one up is marked MIDI. Press that.
  2. The display now says “GM Mode”. Use the Cursor DOWN key to scroll past ‘Keyboard Ch’ and ‘Chord’ - next up is “LOCAL”.
  3. The default for “LOCAL” is “ON”.
  4. Use the + / - keys under the numeric pad to turn ‘Local’ to “OFF”.

Now you should be sending a MIDI signal.

Hope that helps?

Regards,

Neil.

If they used Local in the sense that most manufacturers use Local, it simply means whether or not the sounds are triggered from the keyboard or not, and not have any effect on what you transmit over midi. But it might be different for Casio though.

Thanks guys :slight_smile: i’ll read up on those links later today davefry :slight_smile:

I did this, but funny thing is, I don’ t really know what I did last night, but i pressed the “Synth” button and sett release range to 127 and maybe i changed some other settings there. I have to learn to write down what i do as im doing it, i’m beginning to understand that this is alfa-omega when it comes to exploring uncharted territory by myself, hehe. I don’t know it this is what helped, I don’t think it did, i’ll try and change it back later.
Also, in desperation i pressed the “One Touch (something)” button on the lower left side of the display on the casio, and after that i played for 1 hour or more using different sounds in halion one, without a single key “hanging”.

If this still works tonight, after i changed back the “synth” settings, I may have found the wierdest, most unexplainable sollution to my problem. hehe, wouldn’t be the first time. :slight_smile:

the Local setting seems to only dissable the sound on the speakers on the casio, which is okay to do since i dont really need “Brite Piano” playing on top of some crazy spaced-out sound fx. :smiley:

Like I said, local disconnects they keys from the internal sound source. If you disable local, you can only get the casio to play sounds when sending it midi, not by playing the keyboard. With local on, the casio will respond to both midi and the keyboard. This can be annoying when you created a midi loop which means the sounds will be triggered twice, which is the main reason they invented the Local setting :slight_smile: