Midi signal but no resonse from VST

I am new to Cubase (artist 7). I am using an m-audio m-track as my external sound card. I have my Oxygen 49 midi controller going into the midi slot in the m-track. My question is this: even though when I load Halion sonic, or any other vst instrument for that matter, I get no sound even though I am definitely getting midi input. Even the “red dot” on Halion and the number by the preset lights up when I play the keyboard, but I am getting no sound.

I am pretty sure I have all the sound busses sent out right, because when I use the mouse/arrow to play the virtual keyboard at the bottom of Halion or any other instrument, I get sound, but not when I play my midi controller, even though I am getting a signal. It seems odd that I would get a signal from my midi keyboard but the keys on the virtual keyboard don’t reflect the notes I am playing. I know to send the midi-out to the VST instrument. My input routing is set to “all MIDI inputs” (but also receives MIDI if I set it to M-track external) and my output routing is to whatever VST instrument I have it set for. The MIDI thru is active in preferences.

Eventually I want to learn how to assign all eight midi tracks from my Ensoniq EPS to VST instruments - I’ll be back to ask how to do THAT later . . . right now I just want Halion Sonic (or any other VST) to play when it gets a midi signal!!

System specs are windows 7 64 bit. And yes, the monitor (next to the record button) is enabled. I actually had quit smoking before I bought this program and the stress from spending all this money on a program (and the M-track) that won’t do what I need it to do, since the only instrument I play is keyboards and sequencers, has me smoking again. I really am that stressed out and thinking of returning the product.

I thank anyone in advance for helping me out.

OK, create a new MIDI track.

On that MIDI track, record to it, with you playing the keyboard. Play for a few bars, high and low notes on the keyboard.

Once you’ve stopped recording, highlight that part and open it in the List editor (MIDI > Open List Editor).

What do you see there? if you can post a screen shot of what’s in the list editor it would help.

First of all, djaychela, thank you for responding. I was surprised to see that even though the midi indicator was indicating triggering from my external device, no midi response was recorded in the list editor. I probably would not have even needed to open the list editor to see that no midi parts were being recorded to the track. (I’ve seen screenshots of midi parts on tracks and the other guy in my band has cubase, which is why I got the program - to assist with the production, writing, and mixdown of projects and split the work up.) But yeah, no midi was recorded to the track.

I also noticed some weird timing (is that called latency?) between the striking of keys and the appearance of the indicator line. It happens sometimes, not all the time. :question:

There are two list editor screenshots - one of a plain midi recording and one of a VST recording.

Thank you in advance for your help.
screenshot 2.jpg
screen shot 1.jpg

OK, if you’re seeing MIDI in the indicator, but nothing is being recorded there are two main reasons for that:

  1. The MIDI you’re seeing is “active sensing”, where the MIDI keyboard sends out a “hello” message which isn’t really of much use. If you’re seeing a regular pulse in the indicator with nothing showing, then this is probably the cause.

  2. Your track input may be set to the wrong input in the inspector. If it’s not set to “All MIDI Inputs” then this can be an issue, but from what you say that’s not the issue.

Anyway, given that you’ve tried to record MIDI and got nothing (you were playing the keyboard during the recording, right?) then it sounds like a connection/setup issue, so…

Questions:

  1. You have an Oxygen 49 - that has MIDI and USB connections, right? Any reason you’re not using the USB connection?

  2. You say that the “keys on the virtual keyboard don’t reflect the notes I am playing” - does this mean you see notes but not the ones you’re playing, or nothing at all? If the red dot is lighting up on Halion when you play then -something- must be coming in, and I would have expected the MIDI recording to have captured something, even if it was spurious controller info, or notes at a crazy pitch.

  3. If you download MIDI OX, and turn on the appropriate input in it for your keyboard (there’s a tutorial somewhere for it) and play, do you see note on/off data when you play the keyboard?

There’s nothing at all on the virtual keyboard. I know that the virtual keyboard should react to the midi input. At least I think it should. I think maybe my midi controller is old and sending confusing data - I can’t make heads or tails of the Midi-OX information.

I have my Oxygen 49 running through my Ensoniq EPS, though. So the signal is coming from the Ensoniq. I know what you’re probably thinking, but I was having the same problem using the direct USB input and also connecting the Oxygen directly to the midi in on the external sound device.

When I press any key on the keyboard, a light signals on my external sound card, too. I am attaching a screen shot from Midi-OX - me just playing middle C a few times. Maybe you can tell me what the Midi-OX screen is telling me.

The cubase screenshots are what my settings are and also a sequence is playing through the Ensoniq - I wrote a simple one of just scales up and down and looped it and sent it to cucase. The sound input is the metronome on the Ensoniq playing as I set the instrument to midi only. It seems you’re right, the midi signal for BOTH instruments is not getting through so I am thinking it’s a cubase issue. Once I wrote the part on my Ensoniq (I use the Oxygen 49 to control that as well) and then sent the Enosniq part to Cubase, the Oxygen 49 was no longer part of the equation. If it was the Oxygen, the midi being sent to Cubase from the Ensoniq would have triggered Halion Sonic, I am guessing.

Like I said, I’m real new to all this, and reading the other forum issues here, it usually turns out to be something obvious and simple that someone overlooked. Again, thank you for helping.
Screenshot Midi-midi file.jpg
halion cubase screenshot.jpg
MidiOX middle C.jpg

I am not sure if this is the problem, but I had Windows Updates disabled. After I updated the system, presumably updating the DirectX sound, my M-Audio M-track stopped working. I returned it and I am going to get a Steinberg external audio and midi interface. Probably the UR22, since I only have two instruments - keyboards and voice. I am hoping a Steinberg product will actually work with Steinberg software. Thanks for your help anyway - if you have any additional comments I am welcome to hear them.

OK, going on the MIDI-OX screenshot, I’d say your problem is your keyboard. It’s generating data (hence the input indicator in Cubase and Halion both indicating), but that’s not the data you should be seeing.

When you press a note and then release it, you should see what I’ve screenshotted in MIDI-OX - one event (note on) for the pressing of the note, and another (note off) for the release of it.

It’s impossible to go through a bunch of stuff to find out whether your keyboard is in an “esoteric mode” outputting data like that, or if it’s just broken - my suspicion is actually the latter. If there’s any way you can substitute a known working MIDI keyboard it would be the shortest of short-cuts to faultfinding the situation. While often it is something simple that’s wrong, looking at what you’ve done (which seems to cover the usual “gotchas”), I think a substitution of another keyboard will be the most expedient way to proceed - even if it’s just some crappy old Casio keyboard that happens to have a MIDI out on it that you can get off the free ads for £10.
midi ox.png

I figured it out. It was the M-audio M-track external sound device. I replaced it with a Steinberg UR22 and now it works perfectly. Thank you again though for being patient with me. next, I need to figure out how to get Cubase to accept input from eight different midi channels and assign each channel (from my Ensoniq EPS) to a separate VST instrument so I am playing an actual song. Then I need to figure out how to sync my EPS to cubase so that when I hit “play” on the Ensoniq, Cubase automatically starts recording. I’ve got a lot of work ahead of me, it seems. :smiley:

I had the same issue, I had a keyboard from my neighbor worked fine. Then bought an M Audio 29 key Studio controller didn’t work. What ? I accidentally fixed it when on the channel I clicked the phase button while the M Audio Midi keyboard plugged in. Works fine now. Don’t understand this but it works.

Well, MAYBE i’m able to help u! :wink: GO to “Preferences” then Record-Midi, at the top u can c “record enable allows midi thru” Just select that, apply, et voila. Thats i got it fixed here, hope its of any use 2 u :wink:

I know it’s a while after the OP but that is definitely good advice worth mentioning. Can’t tell you how many times my midi issues when I was learning came down to either record enable not being ticked or more often just forgetting to click record enable. Can’t stand that ‘record enable when selecting track’ setting, am in the habit of checking now so no problems.

That phase button ‘solution’ you mention sounds like a bug PGApromike, would be interested to see if you learnt any more about it since posting.

Hi! I have the same problem, I red the whole post but I can’t fix the problem.

In my case:

cubase 6 artist
Novation SL MK II

I get the MIDI signal in the transport bar. (see pic ‘‘midi problem01’’)

When I play the keyboard (with the mouse) directly on the VST, then I get sound (see pic ‘‘midiproblem04’’). But not with my MIDI keyboard.
I installed, and reinstalled the drivers, automap, etc with no result. A few weeks ago I was changing the synchronization setup, to set the tempo of my external machines (virus ti, korg volca, etc) to the Cubase tempo. But I noticed that the Keyboard don’t work and I tryed to undone and no good result. (see pic ‘‘midi problem03’’)

I try to set the same midi channel but I really don’t understand this settings, It’s in the default position (see pic ‘‘midi problem02’’)

I opened the vst on a instrument track, selection the RECORD, and the MONITOR, button… I don’t know more options to try to solve this problem.
If someone has the same problem and fixed it, say me please how to do it.

Thanks to all!

J.Piles
midi problem03.jpg
midi problem04.jpg
midi problem01.jpg

It looks like your keyboard is sending midi. Thats good. Now try these steps…

In project page have the inspector section visible.

  • Highlight a instrument or midi track and click on the track number that is shown in in the upper left of the inspector.
  • That will drop down the input section. Choose “all midi inputs”
  • Below that is a place where you choose your vst instrument. Choose any one you want.
  • Open the vst plugin panel and choose a sound from that list.
  • Close the plugin and click the button to activate the vst. I believe it is an “e” button on the track. It will be blue when activated.
  • Click the record enable and monitor buttons on the track.
  • At this point you should be able to hear your chosen sound when you press on the keyboard.
  • To record you must now press the record button on the transport. I dont think you did this step.
  • To play back the recorded midi you must shut off the record enable and monitor buttons on the track.
  • Press the play button on the transport. Hopefully you will be all set.

Regards. :sunglasses: