MIDI signal but no sound-please help all treads on the matter did no help

I can see the midi activities but I am unable to make my keyboard received by the VST instrument or any other midi channel.
I have read all the post dealing with the same issues and nothing seem to work.
My midi keyboard is even controlling the play record stop, volume option fine. But not way I can make a sound.
All midi input is selected, I create a new project from scratch using the JAzz recording template, I see my Keyborad in the midi input .

Really need help here I am running insane
Thank you

Hi and welcome,

Is your MIDI Controller part of the “All MIDI Inputs”? Double check this in Devices > Device Setup MIDI Port Setup.

Double Check MIDI Filters in the Preferences > MIDI > MIDI Filter. Make sure Note is not enabled in the filter. Also make sure no Channel is enabled.

If you use your hardware as any kind of Remote Device, try to set the Remote Devices’ input to Not Connected.

I’m not at my workstation, but if this can help…

which VST instrument are you using?
Be sure that the sound you want to use is ‘loaded’ into the VST instrument.
I think when you select the sound, you double-click to load it.