MIDI signal but no sound.

Hi everyone,

I’ve used Cubase for 10 years now and I have never seen something like this.

Everything was working fine for me until a few days ago I couldn’t make any sound like usual.

When I select a track and I play on my keyboard there is no sound, I can see the MIDI signal in the transport, everything is well assigned, I even get sounds when I click on the keyboard in Kontakt or other VST, but nothing with my keyboard.

But what is really wierd is that when I click the “enable record” button my keyboard works just fine the thing is that it keeps playing the instrument of the track where the “enable record” is activated even when an other track is selected (which is normal). For now I can work at least like that but it’s really anoying because I have to activate “enable record”, work on the track, desactivate “enable record”, etc … etc …

How can i do to be able again to play an instrument just by selecting the track ?

In the preference the MIDI thru is activated as well as “Record-Enable allows MIDI Thru” (the problem is still the same when this option is active or not).

I have searched on different topic but nothing so far, please help !

I usually have Monitor mode/style as manual - so I activate when I want monitor or not.

You don’t want this - so look at settings how activation of track acts - if record and monitor is automatic or not when track selected.

There are separate options for midi tracks and audio tracks, as I recall.

Thanks a lot for your answer !

Yes you have separate option for MIDI tracks and audio tracks and in deed, in preference => VST, you got option for the automatic monitoring. I have tried them all and nothing so far, with and without the “Record-Enable allows MIDI Thru” option.

On Editing midi tab in Preferences:

"Enable Record on Selected MIDI Track
If this option is activated, the selected MIDI tracks are automatically recordenabled.

Enable Record on Selected Audio Track
If this option is activated, selected audio tracks are automatically record-enabled."

This was what I was thinking of also in combination with monitoring mode.
Odd place to have that setting there - it should be on Record as I see it.

Ok so the problem is solved. It was in deed these option to enabled (don’t know why or how they were unabled in the first place though), they are in Preference => Edition => Project and MixConsole, very odd place to put these options in deed !

Anyway thank you very much Larioso for your answers !

You’re welcome. :slight_smile:

Thanks for the tip. Had the same issue. Midi Input was active but no sound. Solved it by changing the “Record Enable” Option in the preferences.

In Cubase 9.5 go to Preferences > Editing > Project & MixConsole >

Then activate: “Enable Record on Selected Midi Track”

That did the trick. Also no idea why that got changed after I installed the latest update. I certainly did not change it. Although…

… I find saving preferences in Cubase VERY odd. I never really know if my custom or default preferences are loaded or not. If I make changes and have not pre-loaded my custom preferences, obviously nothing gets saved in my custom preferences. It would be helpful and more intuitive, if the last saved preferences are automatically loaded on start AND the custom preference name is displayed. This would make it a lot clearer to anyone using Cubase which settings are actually active or not. The way it stands now, its always a spooky guessing game… Also, for some strange reason, I cannot simply choose my existing preference name when saving (like in a standard drop down menu), but I always have to re-type the name manually. Its not killing me, but its annoying and surely an easy fix.