MIDI Starts to record 1 bar before my Cycle marker starts?

Hello, I often use cycle recording and have it set to when I press record, it automatically starts at the beginning of my left marker. But every time I do, it starts the recording 1 bar before it. It’s rather annoying as I constantly have to delete that little part in the beggining to keep it all clean. Any thoughts on how I can correct this?

Do you happen to have pre-roll enabled?
If so, just disable it :wink:

I checked it just now and I did not have pre rolled enabled. I did notice when I uncheck “click during count in” in the metronome setup window, it doesn’t do it but of course I can’t hear my click in and it just starts right away which is not what I want. This is a little thing but very frustrating.