Midi stopped working

(Cubase 11 pro) - I have been a Cubase user for many years. I have made an adjustment to midi filter in preferences, but reverted the changes, but it seems the filter is still in place.

The Problem: Midi data no longer is received by the track / rack instrument.
What caused it: in Preferences → midi filter I selected under record, “Note” and “Controller” check boxes whilst trying to sort out an expression pedal. I then immediately returned to the same menu, uncheecked the two boxes and hit apply. No other buttons etc have been changed

  • midi data is correctly received in cubase (and I have checked this in a different midi program) but no sound from the plugin. However if I play the screen keyboard in the plugin, it works ok
  • This is not an issue in my copy of Cubase 10.5 - everything works fine
  • I have reloaded Cubase, switched off the computer and loaded cubase with default factory preferences - the fault is the same.

So to summarise - cubase has been working fine (for years) - its worked fine all today. Tonight I selected in the pref menu the two options listed earlier. Moments later I unchecked these and applied - this is when midi stopped. Nothing else changed

It seems like Cubase 11 Pro has kept those preferences despite them visually seeming to be ok

Any help would greatly be appreciated


Do you use and Remote Device by any chance? Is the MIDI Port you are using part of the All MIDI Inputs?

Hi - thanks for the reply. I have removed all references to the keyboard being used as a controller i.e. any mackie control, quick controls etc. I also removed the keyboard from ALL MIDI and tried setting the track midi input direct from the keyboard - still no midi signal

Remember: regardless of the above, it all worked fine (for years) with the keyboard set as a transport controller. The fault only occurred after i made some selections in midi filter menu, then deselected those settings (so back to default) - then the fault occurred.

I do remember a post many years ago about a version of Cubase not recalling the correct preferences settings even when boxes are unticked (Cubase acts like they are still ticked) - I can’t recall the post now as it is many years ago


Could you try in the Cubase Safe Start Mode [Disable preferences], please?

OK - so I have found a “fix”

I went to C:\Users[USERNAME]\AppData\Roaming\Steinberg

I then put an “x” in front of the folder “Cubase 11_64” so now it read xCubase 11_64 (apparently it is important to change the front of the folder name as changes at the rear are ignored by cubase)

Fired up Cubase 11 again, this created a new CUBASE 11_64 folder and now midi works. Hopefully this proves there is a bug in the preferences settings i.e. changes in the midi filter pref menu are not actually changed


OK, so you trashed Cubase preferences. :wink:

yeah! Annoying as one has set up generic remotes etc again. Not that much of a hassle I know, but it interupts work flow and creativity!


I feel your pain… You can export the Generic Remote setup and import it to the “new” Cubase preference after.

Yes - I saved three remotes BUT here is the fun thing (and yet again another bug) - preferences does not remember all the commands entered into a remote! I can set a remote up, I can get it working fine. I can export it. Come out of cubase, go back in, renmnote not working as expected. Check remote settings - cubase has lost one of the CC controls. use import - it imports minus the correct CC setting.

Not one to answer in this thread I think as will be mixing two different issues. But to say, Im not impressed with Cubase pref settings (I see people can have issues with colour schemes being retained). Here’s hoping Cubase 12 delivers a bug free environment…

Color schemes. Generic Remote and many other bugs.

Steinbergs answer is to trash your prefs file. Its been this way since SX1 here

1 Like

I just got bit by this same bug 2 days ago. Instrument track quit taking MIDI via even All MIDI Any CH. My workaround was to use an existing MIDI track I was using to record keyboard inout and MIDI send it to the instrument track, It worked, getting through my work but had been looking for cause of this. Note I have not messed with Prefs / MIDI at all :frowning: and on OS 12.3. I too have the transport controls on Arturia key lab 61 mk2 set as HUI and they work. Almost seems like bug kicked in when I used the Rec and Stop buttons on it.

OS 12.3 ??? I didn’t know 12.3 was out yet

Public beta Apple Beta Software Program

I don’t do betas here. Im more comfortable using a hacked EFI Bootloader to run Apples current OS which isn’t compatible with my 2013 iMac. :grinning:

12.2.1 just came out today.

I have not had this issue here but when I do I will report back.