midi sync problem in record

I use Cubase 10.5.20 Ai Elements master to a Yamaha Tyros 5 keyboard as slave. Cubase is on an i7 Windows computer syncing via a Midisport 2x2 interface.

Cubase outputs a midi clock when stopped.
When I press play on the keyboard it syncs correctly with this clock signal. I see the beat light flashing at the correct speed on the keyboard.
However when I press record on Cubase (without touching the keyboard), the midi clock out seems to be double the frequency. The beat light on the keyboard changes to double the frequency. The drum patterns on the keyboard play at double the rate.

Is there any command in Cubase which affects the midi clk out?

I have been using midi forever so I am sure everything I know about is setup correct.
The keyboard doesn’t accept MTC as far as I know.
I have turned off midi thru and soft thru.


Problem solved. Was sending midi clock to Tyros5 Midisport 2x2 and MIDISPORT 2x2. I just needed to scroll down the options and I would have seen that it was going out twice. :smiley: