MIDI timing wrong on playback

Hi

When playing recorded MIDI recorded track, the timing is completely off.

What should I do?

Thanks.

Shay.

Have you tried ticking the use system timestamp box?

Where is this box ?

(Cubase 6)

Many thanks.

Shay.

Lurking around the Device Setup Menus somewhere!

Are you sure it exist in Cubase 6? I looked and looked and can’t find it.
I also checked the operation manual for the words “timestamp” or “stamp” and they don’t appear there even once.
Thanks.
Shay.

MDI Port Setup

Wonderful!

Many thanks guys.

It solved the problem :slight_smile:

Check you system clock or external clock settings both in Cubase and whatever devices (keyboards with built in sequencers or drum machines etc) are attached to your rig.
Something else is telling Cubase where to put the midi whereas Cubase, in most cases, needs to be the master clock.

Sometimes though the cause cannot be found.

Please read this wonderful article:
http://www.soundonsound.com/sos/dec07/articles/cubasetech_1207.htm
It describes the technical background of this issue and shows you how to get most accurate MIDI timing out of your system.