MIDI to DM 1

Hi all,

Apologies if this has been answered before, but its driving me insane. I want to send MIDI out to trigger drums in DM 1. I have set Cubasis to output MIDI to DM 1, set DM 1 to receive MIDI/notes from CB. Checked that I’ve created the correct notes in MIDI I.e. note 36 for the bass drum etc. Nothing happens no sound, no recording…

All this is via Audiobus btw. I have checked using an iRig MIDI that there is MIDI coming out of CB, and using an Akai LPD that DM 1 will receive MIDI. Both work perfectly.

Both DM 1 and CB are the latest versions, as is Audiobus. iOS is V 6.1.3

I don’t have tis problem with Sunrizer, PPG Wave, Polysix, so I suspect somewhere there is a problem with DM 1.

Any help would be greatly appreciated.
Max the dog.

Is background audio selected on?

Hi Context,

Yep, its on. I tried to switch it off, but if you’re using Audiobus DM won’t let you switch it off.

Have just been having another go at getting it work; playing the pads in DM straight into CB, the audio works fine. There’s obviously something not right getting MIDI into DM from CB and getting MIDI out of DM into CB.

Maybe one ( or both) need an update.

M t D

Yeah if you can trigger Cubasis with DM1 but not the other way around then something is fundamentally wrong there. Only thing I can think of outside of just calling it a bug is your midi channel assignments, but it sounds like you’ve got everything all set up. Can you trigger DM1 with any other apps?


I’ve tried all the options available in the MIDI in /out fields - DM,Virtual, Network, etc on various MIDI channels including omni. Also done the same with the options back in on the audio channel - nothing doing.

I tried sending the same stream of MIDI notes from the CB track into Sunrizer and at the same time recording the resulting audio back into CB - perfect! So I think CB is off the hook.

As for triggering DM with something else,I’ll try it tonight. Got a choice of Beatmaker, Little MIDI machine, and StepPolyArp. I’ll soon know, but I’m suspecting that DM’s MIDI credentials are not what they appear. :frowning:

Thanks for your replies.

M t D

Unfortunately, midi standards are tossed out the window with iOS apps. On the plus side, I’ve found that most iOS developers are pretty good at answering emails and addressing problems with their apps. So if all else fails, contact the dev directly and if it is a bug we’ll probably see an update in a week or two. Let us know how you make out.

Edit: Is this happening without Audiobus as well? Chordion has a similar issue where midi out won’t work with some apps when Audiobus is turned on.

Well now I’m convinced - just tried DM with Little MIDI machine an StepPolyArp. Didn’t bother with Audiobus and it didn’t work with either.

So will try the developers…

Had also this problem first. Just use Virtual Midi for the output, that works for me. Than you can play DM-1 via Cubasis MIditrack.
You also have to choose “No instrument”. By default new midi tracks are loaded with Acoustic Piano.
This all with Audiobus.
Audiobus Forum is also a good and reliable source for questions.

Many thanks, Bigsoundgood.

M t D