MiDi track sounds diffrent while I play it and diffrent after i recorded it

Hey, I’m using cubase elements 11 version. While i play on midi instrument everthing sounds great but after i record it… it sounds totally diffrent ( squashy and cut ). This problem dissapears when I turn on “auto quantize in record” option - then all sounds same as original but… i dont want want to quantize for playing piano… what I am doing wrong?? please somebody help.

Hi! Disable “Auto Quantize in Record”.

This option:

1 Like

okay, thank you for answer. But when i do that - i have diffrent sound on recorded track than while i I am playing it

Hi Matt and welcome to the forums!

Could you describe in more detail how it sounds different? Could some screenshots aid in explaining the issue?

If your midi instrument indeed is an external synth/keyboard kindly set it to ‘Local Off’ (has to be done on the synth itself).

1 Like

Sorry. I didn’t pay too much attention to what you have said. Can you please select the track, take a screenshot, then upload it here? It would be useful to know what track type you’re using, and if you’re using a VST instrument on the track’s output routing.

thank you all for your asnwers. Here is more details to make it more clealer i hope.
Im using M-Audio hammer88 pro midi keyboard. Here’s some step i will do for example :
I am creating a new instrument track in cubase elements 11

Then I am choosing a toonetrack drum plugin.

Plugin sound great while playing.
here is my setup in ‘transport’ before recording :

i recorded it with “quantize” option and it sounds great - same sound as one while i played it before recording.
here it is : ( forum doesnt allowed me to paste link so i had to insert some spaces )
soundcloud. com/ mateusz-fitkowski/ sample-1-with-quantize

And now i turn off quantize, becouse i dont always neeed to use this option on my tracks :

And i recorded it again. while recording - plugin sounds still great, but after recording… please take a listen here :
soundcloud. com/mateusz-fitkowski/sample-2-without-quantize
To be clear i will say again. While recording it sounds great… after recording it sounds like there is a change - it sounds worse, less quality…
maybe i did something wrong… or didnt do something witch is nesessary. But i have no idea.
@Johnny_Moneto you said about “local off” but i have no ideal where is such a option even placesed, i dont see it on keyboard.
What else would you suggest to check? I hope you all have wonderful night

My suggestion aimed at using a hardware synth. But you are using virtual instruments so just kindly ignore my comment.

What else to check?
I would set up a track with Retrologue 2 on it and see if the same problem happens there as well. From your screenshot I see that you are using instruments that are, how to say, multiple instruments-in-one. Retrologue is a rather simple synth. Thereby you can check whether the problem lies with Cubase or with the settings within the VSTi.

1 Like

Both recordings sound the same to me, basically. There are some timing issues in the second one, though, and both slight level and reverb settings differences between the two. So, beside these, I see no functional issue on your case.

Concerning the ‘local off’ parameter, it is a common setting on synths to avoid any added sound triggering in the synth itself to the MIDI messages sent. But, as you are using a MIDI controller, it’s not applicable.

1 Like

already checked… this happen with every virtual instrument

Hi Matt,
I’ve listened the files, and for me the file without quantize sounds obiously doubled. Not sure if this helps, but it sounds to me as the notes are recorded twice or played back twice at the same time.

you are right, but the only thing i changed is “auto quantize”. I found something - it looks like cubase switch sample rate of the track after recording. It done test. Recorder track without quantize sounds exxacly the same like when you change sample rate to very low value… but stilll i dont know how to fix it