Midi tracks - proper instrument does not play when export

Hi, there. I am a very new Cubase Elements 7 user (using Halion SE plugin) and I know this is a basic question that has probably been addressed elsewhere, but I don’t understand what i am doing wrong.

  1. How do I take midi tracks that are playing the wrong instrument and make them PERMANENTLY play back the right instrument? My flutes are assigned “keyboard”, and when I change to “flute”, the program switches it back to “keyboard” as soon as I play back.

  2. How do I take those midi tracks with the correct instrumentation and record to an audio track while recording ONLY the track, not the sounds the mic is picking up from the room?

I greatly appreciate your help. It is vital that I make these midi tracks sound like their assigned instruments.

Look at the midi part(s) in list view and delete any program changes, you can filter for that.

That’s usually what’s happening is there’s embedded midi events when you use midi files you get off the internet etc.

Can you tell me how to access the list view function? I cannot seem to find it anywhere. Thanks!

Thanks. I don’t see the “list view” in Cubase Elements 7. Can you tell me how to find that?

I did find “program change” as a drop down option in the midi file, but there is no information in the lane, the line is at zero. BUT…for the first time, I can change the sound by using the pencil and creating a line at a given number (79= GM Pan Flute, for example).

I was thinking it’s in the view menu after you highlight a midi part.

Not sure about your version though, does it show up in your manual?